summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcgroup')
-rw-r--r--dev-libs/libcgroup/libcgroup-0.41-r6.ebuild35
1 files changed, 20 insertions, 15 deletions
diff --git a/dev-libs/libcgroup/libcgroup-0.41-r6.ebuild b/dev-libs/libcgroup/libcgroup-0.41-r6.ebuild
index 14021a85a767..f0164a2fa06c 100644
--- a/dev-libs/libcgroup/libcgroup-0.41-r6.ebuild
+++ b/dev-libs/libcgroup/libcgroup-0.41-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools flag-o-matic linux-info pam systemd
@@ -13,18 +13,27 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="+daemon elibc_musl pam static-libs test +tools"
+REQUIRED_USE="daemon? ( tools )"
-RDEPEND="pam? ( virtual/pam )"
+# Use mount cgroup to build directory
+# sandbox restricted to trivial build,
+RESTRICT="test"
-DEPEND="
- ${RDEPEND}
+BDEPEND="
sys-devel/bison
sys-devel/flex
elibc_musl? ( sys-libs/fts-standalone )
- "
-REQUIRED_USE="daemon? ( tools )"
+"
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-replace-DECLS.patch
+ "${FILESDIR}"/${P}-replace-INLCUDES.patch
+ "${FILESDIR}"/${P}-reorder-headers.patch
+ "${FILESDIR}"/${P}-remove-umask.patch
+)
-DOCS=(README_daemon README README_systemd INSTALL)
pkg_setup() {
local CONFIG_CHECK="~CGROUPS"
if use daemon; then
@@ -56,6 +65,9 @@ src_prepare() {
sed -i '/^SUBDIRS/s:tests::' Makefile.am || die
fi
+ # Workaround configure.in
+ mv configure.in configure.ac || die
+
eautoreconf
}
@@ -75,16 +87,9 @@ src_configure() {
${my_conf}
}
-src_test() {
- # Use mount cgroup to build directory
- # sandbox restricted to trivial build,
- # possible kill Diego tanderbox ;)
- true
-}
-
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
insinto /etc/cgroup
doins samples/*.conf