summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/denote/Manifest1
-rw-r--r--app-emacs/denote/denote-2.3.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/denote/Manifest b/app-emacs/denote/Manifest
index 6fdcab3577d6..2a8e1eff0633 100644
--- a/app-emacs/denote/Manifest
+++ b/app-emacs/denote/Manifest
@@ -1 +1,2 @@
DIST denote-2.2.0.tar.gz 206136 BLAKE2B f2740d4428130cd3583e139cb4bdd4a48d8ab93b112b584710258474217f1569177ee8a62d75c7324d84118fa608ac737e894014acbbd59ac2659b3c93e01543 SHA512 f6243b04a12efbcb3339fcdddabc1ea9d14ab56398616a15db2170834b5ecc66556f5bbc15fad8775b33191742706e5a469839c5ea18bc07a1669c2750604915
+DIST denote-2.3.0.tar.gz 230151 BLAKE2B 05ad19b846793cc504f1791ca4fb5a4fe97f9cf624e7c5db465c9b1d42644db2cd163ce4c2cb865bb2f1aa94e4a3b39568ec670b27912bce0cf707beb0917f70 SHA512 41c70dbacfbcbe0efb5134ed0f6573f9dab9fc9700ec4e947c809f423b2facc84a09f17ec50a7b1fe8c588f8ce0402b71ce24e7161df1531714598a94a6ffad5
diff --git a/app-emacs/denote/denote-2.3.0.ebuild b/app-emacs/denote/denote-2.3.0.ebuild
new file mode 100644
index 000000000000..f665dafb38c0
--- /dev/null
+++ b/app-emacs/denote/denote-2.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=28.1
+
+inherit elisp
+
+DESCRIPTION="Simple notes for Emacs with an efficient file-naming scheme"
+HOMEPAGE="https://protesilaos.com/emacs/denote/
+ https://github.com/protesilaos/denote/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Some tests fail.
+
+DOCS=( CHANGELOG.org README.md )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}