summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.2-r1.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.2-r1.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.2-r1.ebuild
index 7ebe0572a78b..ada76ed82820 100644
--- a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.2-r1.ebuild
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.9.2-r1.ebuild
@@ -30,11 +30,6 @@ python_compile() {
}
python_test() {
- # this is needed to keep the tests working while
- # dev-python/namespace-ruamel is still installed
- cat > "${BUILD_DIR}/install$(python_get_sitedir)"/ruamel/__init__.py <<-EOF || die
- __path__ = __import__('pkgutil').extend_path(__path__, __name__)
- EOF
+ distutils_write_namespace ruamel
epytest
- rm "${BUILD_DIR}/install$(python_get_sitedir)"/ruamel/__init__.py || die
}