summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nDPI/nDPI-2.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-libs/nDPI/nDPI-2.0.ebuild b/net-libs/nDPI/nDPI-2.0.ebuild
index 7d4217d49afe..f512638e13d6 100644
--- a/net-libs/nDPI/nDPI-2.0.ebuild
+++ b/net-libs/nDPI/nDPI-2.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools eutils multilib
DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
HOMEPAGE="http://www.ntop.org/"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="static-libs"
DEPEND="dev-libs/json-c
net-libs/libpcap"
@@ -21,3 +21,11 @@ src_prepare() {
default
eautoreconf
}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN,,}.a || die
+ fi
+ prune_libtool_files
+}