summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2020-06-07 00:57:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 08:55:52 +0200
commitb75291a9e68d6f173dfa5a59aee38dc12191900f (patch)
tree87e923aa1b94c1bffd45a106b9de879d0c44aed3 /xfce-base/xfce4-settings
parentxfce-base/xfce4-settings: update dependency versions (diff)
downloadgentoo-b75291a9e68d6f173dfa5a59aee38dc12191900f.tar.gz
gentoo-b75291a9e68d6f173dfa5a59aee38dc12191900f.tar.bz2
gentoo-b75291a9e68d6f173dfa5a59aee38dc12191900f.zip
xfce-base/xfce4-settings: fix missing icons in xfce4-settings-manager
The added patch file is specific to version 4.15.1. The issue has been fixed in upstream master, so the patch file won't be needed in version 4.15.2/4.16. Upstream bug: https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/176 Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16101 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfce4-settings')
-rw-r--r--xfce-base/xfce4-settings/files/xfce4-settings-4.15.1-install-icons.patch70
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.15.1-r1.ebuild (renamed from xfce-base/xfce4-settings/xfce4-settings-4.15.1.ebuild)4
2 files changed, 74 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/files/xfce4-settings-4.15.1-install-icons.patch b/xfce-base/xfce4-settings/files/xfce4-settings-4.15.1-install-icons.patch
new file mode 100644
index 000000000000..2d84b8e7637d
--- /dev/null
+++ b/xfce-base/xfce4-settings/files/xfce4-settings-4.15.1-install-icons.patch
@@ -0,0 +1,70 @@
+# Upstream issue: https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/176
+# This issue has been fixed in upstream master, so this patch won't be need in the future.
+
+--- ./Makefile.am 2020-05-27 02:54:17.000000000 +0200
++++ ./Makefile.am 2020-05-30 23:53:57.647209221 +0200
+@@ -6,15 +6,11 @@
+ xfce4-settings-manager \
+ xfce4-settings-editor \
+ xfsettingsd \
+- po
+-
+-if HAVE_COLORD
+-SUBDIRS += \
++ po \
+ icons
+
+ distuninstallcheck_listfiles = \
+ find . -type f -print | grep -v ./share/icons/hicolor/icon-theme.cache
+-endif
+
+ EXTRA_DIST = \
+ intltool-extract.in \
+--- ./Makefile.in 2020-05-27 03:07:44.000000000 +0200
++++ ./Makefile.in 2020-05-30 23:54:08.477620446 +0200
+@@ -87,10 +87,6 @@
+ POST_UNINSTALL = :
+ build_triplet = @build@
+ host_triplet = @host@
+-@HAVE_COLORD_TRUE@am__append_1 = \
+-@HAVE_COLORD_TRUE@ icons
+-
+-distuninstallcheck_listfiles = find . -type f -print
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/configure.ac
+@@ -160,8 +156,7 @@
+ ETAGS = etags
+ CTAGS = ctags
+ CSCOPE = cscope
+-DIST_SUBDIRS = common dialogs xfce4-settings-manager \
+- xfce4-settings-editor xfsettingsd po icons
++DIST_SUBDIRS = $(SUBDIRS)
+ am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in AUTHORS \
+ COPYING ChangeLog INSTALL NEWS README TODO compile \
+ config.guess config.sub install-sh ltmain.sh missing
+@@ -463,10 +457,17 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+-SUBDIRS = common dialogs xfce4-settings-manager xfce4-settings-editor \
+- xfsettingsd po $(am__append_1)
+-@HAVE_COLORD_TRUE@distuninstallcheck_listfiles = \
+-@HAVE_COLORD_TRUE@ find . -type f -print | grep -v ./share/icons/hicolor/icon-theme.cache
++SUBDIRS = \
++ common \
++ dialogs \
++ xfce4-settings-manager \
++ xfce4-settings-editor \
++ xfsettingsd \
++ po \
++ icons
++
++distuninstallcheck_listfiles = \
++ find . -type f -print | grep -v ./share/icons/hicolor/icon-theme.cache
+
+ EXTRA_DIST = \
+ intltool-extract.in \
+ dist-tarZ: distdir
+ @echo WARNING: "Support for distribution archives compressed with" \
+ "legacy program 'compress' is deprecated." >&2
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.15.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.15.1-r1.ebuild
index 36bdf55c705f..396625415b5d 100644
--- a/xfce-base/xfce4-settings/xfce4-settings-4.15.1.ebuild
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.15.1-r1.ebuild
@@ -40,6 +40,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext
x11-base/xorg-proto"
+PATCHES=(
+ "${FILESDIR}"/${P}-install-icons.patch
+)
+
src_configure() {
local myconf=(
$(use_enable upower upower-glib)