summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/arandr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/arandr')
-rw-r--r--x11-misc/arandr/Manifest2
-rw-r--r--x11-misc/arandr/arandr-0.1.7.1.ebuild38
-rw-r--r--x11-misc/arandr/arandr-0.1.8.ebuild38
-rw-r--r--x11-misc/arandr/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/x11-misc/arandr/Manifest b/x11-misc/arandr/Manifest
new file mode 100644
index 000000000000..6865c80dc0a8
--- /dev/null
+++ b/x11-misc/arandr/Manifest
@@ -0,0 +1,2 @@
+DIST arandr-0.1.7.1.tar.gz 82118 SHA256 ab73aa90d05d48b95a01afdad37b7c21a2cdf4af98f7d78b2502b819382748da SHA512 1e3b8ec0d98d38515a159c7695abefd7451a3fa6b7d43641766c997aab63152dfa76c2d9208ba2848ce588dd033a8e85ae31b97acdd4aa5e450fd87725cc21ce WHIRLPOOL 9f9844cb0cb14fcba17767a1b50270843c70859253d96c23d3d47c65b64d5740fcdbad888d97f60fd1ae5f13245098d11c6b9552a221938c8b3b183146ffdf4c
+DIST arandr-0.1.8.tar.gz 86930 SHA256 6d8ec18e2f683818f420502516f7ece6c377a1903eab1de781152b585725a734 SHA512 3038677d92596aa63233ecd6fa8c1cb0d3522bc8aa69912aa79be900059c37bdda14efe9c17dc16a4c5858ebeeee7f62a55156b6e47e0715f1a341e8ad3c4f11 WHIRLPOOL 91f4810e732289b01dbaa9173a684d7c4c338a78a4b26d0314da99abc491adf30da7067c8657ac024c61cdc8d7c018c120c51bd104ae182b50761f33b6891e6a
diff --git a/x11-misc/arandr/arandr-0.1.7.1.ebuild b/x11-misc/arandr/arandr-0.1.7.1.ebuild
new file mode 100644
index 000000000000..190e6db25e98
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A simple visual frontend for XRandR 1.2/1.3"
+HOMEPAGE="http://christian.amsuess.com/tools/arandr/"
+SRC_URI="http://christian.amsuess.com/tools/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2[${PYTHON_USEDEP}]
+ x11-apps/xrandr"
+DEPEND=">=dev-python/docutils-0.6[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ local i p
+ # simulate gettext behavior:
+ # LINGUAS unset => install all
+ # LINGUAS="" => install none
+ # LINGUAS="de fr" => install de and fr
+ if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
+ for i in $(cd "${S}"/data/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
+ if ! has ${i} ${LINGUAS} ; then # if language is disabled
+ rm data/po/${i}.po || die
+ fi
+ done
+ fi
+ distutils-r1_src_prepare
+}
diff --git a/x11-misc/arandr/arandr-0.1.8.ebuild b/x11-misc/arandr/arandr-0.1.8.ebuild
new file mode 100644
index 000000000000..c7da8ab744b6
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A simple visual frontend for XRandR 1.2/1.3"
+HOMEPAGE="http://christian.amsuess.com/tools/arandr/"
+SRC_URI="http://christian.amsuess.com/tools/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2[${PYTHON_USEDEP}]
+ x11-apps/xrandr"
+DEPEND=">=dev-python/docutils-0.6[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ local i p
+ # simulate gettext behavior:
+ # LINGUAS unset => install all
+ # LINGUAS="" => install none
+ # LINGUAS="de fr" => install de and fr
+ if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
+ for i in $(cd "${S}"/data/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
+ if ! has ${i} ${LINGUAS} ; then # if language is disabled
+ rm data/po/${i}.po || die
+ fi
+ done
+ fi
+ distutils-r1_src_prepare
+}
diff --git a/x11-misc/arandr/metadata.xml b/x11-misc/arandr/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/x11-misc/arandr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>