summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libXpm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libXpm')
-rw-r--r--x11-libs/libXpm/Manifest2
-rw-r--r--x11-libs/libXpm/libXpm-3.5.10-r1.ebuild29
-rw-r--r--x11-libs/libXpm/libXpm-3.5.10.ebuild27
-rw-r--r--x11-libs/libXpm/libXpm-3.5.11.ebuild29
-rw-r--r--x11-libs/libXpm/metadata.xml5
5 files changed, 92 insertions, 0 deletions
diff --git a/x11-libs/libXpm/Manifest b/x11-libs/libXpm/Manifest
new file mode 100644
index 000000000000..17ba87f367a8
--- /dev/null
+++ b/x11-libs/libXpm/Manifest
@@ -0,0 +1,2 @@
+DIST libXpm-3.5.10.tar.bz2 431310 SHA256 a6db7e234750e7d60330017972e31d8e1f29f0a8c1391e4ac82f6102d919a735 SHA512 27ddf49ec13e77ee89cc3dfcf95631576a941e9fab18bfa1bbe2d45e8979548793f8723ffa4d97db7fdb4909883f9efa2c7d6e2996696f82940fdd7518e2c49d WHIRLPOOL ac4871d7b3e5fe90cdd0b6f31fb00fa26dd35985027947dd116a20b5738ed290804b84d70ebcc52577235045cb1272dbe0b04512630c47b8b26b679008a78fa4
+DIST libXpm-3.5.11.tar.bz2 443496 SHA256 c5bdafa51d1ae30086fac01ab83be8d47fe117b238d3437f8e965434090e041c SHA512 c089056108d4598f6c4603d6440d9ef6216e87c5cf1e30d143b0e7abc9c5d6f40050c747a57a27d751bc80786ded0390d97cbe221be628241c881d21a3ce6024 WHIRLPOOL d2b60fcfe2b591a452074e2bb9ba7f22ce705f86716a547bf9a8b75454c6e5f06848086880f14459440ca4106f1b3247f84de2fb705686082c34a5194e38d484
diff --git a/x11-libs/libXpm/libXpm-3.5.10-r1.ebuild b/x11-libs/libXpm/libXpm-3.5.10-r1.ebuild
new file mode 100644
index 000000000000..0da1ddad56b0
--- /dev/null
+++ b/x11-libs/libXpm/libXpm-3.5.10-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xpm library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ # the gettext configure check and code in sxpm are incorrect; they assume
+ # gettext being in libintl, whereas Solaris has gettext by default
+ # resulting in libintl not being added to LIBS
+ [[ ${CHOST} == *-solaris* ]] && export ac_cv_search_gettext=-lintl
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libXpm/libXpm-3.5.10.ebuild b/x11-libs/libXpm/libXpm-3.5.10.ebuild
new file mode 100644
index 000000000000..da0cd6b9d816
--- /dev/null
+++ b/x11-libs/libXpm/libXpm-3.5.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit xorg-2
+
+DESCRIPTION="X.Org Xpm library"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-proto/xextproto
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ # the gettext configure check and code in sxpm are incorrect; they assume
+ # gettext being in libintl, whereas Solaris has gettext by default
+ # resulting in libintl not being added to LIBS
+ [[ ${CHOST} == *-solaris* ]] && export ac_cv_search_gettext=-lintl
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libXpm/libXpm-3.5.11.ebuild b/x11-libs/libXpm/libXpm-3.5.11.ebuild
new file mode 100644
index 000000000000..1c4c1b4a648d
--- /dev/null
+++ b/x11-libs/libXpm/libXpm-3.5.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xpm library"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ # the gettext configure check and code in sxpm are incorrect; they assume
+ # gettext being in libintl, whereas Solaris has gettext by default
+ # resulting in libintl not being added to LIBS
+ [[ ${CHOST} == *-solaris* ]] && export ac_cv_search_gettext=-lintl
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libXpm/metadata.xml b/x11-libs/libXpm/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-libs/libXpm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>