summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-08-23 09:45:46 +0200
committerEli Schwartz <eschwartz@gentoo.org>2024-08-25 16:23:24 -0400
commit60c762aebda5b24c14976c5b468a78d5eb5ed1b0 (patch)
tree2b8c8f45d576d3eb391e5e73a3bdbac4ef535d9f /www-apps/radicale
parentsci-geosciences/grass: drop 8.3.2, 8.4.0_rc1 (diff)
downloadgentoo-60c762aebda5b24c14976c5b468a78d5eb5ed1b0.tar.gz
gentoo-60c762aebda5b24c14976c5b468a78d5eb5ed1b0.tar.bz2
gentoo-60c762aebda5b24c14976c5b468a78d5eb5ed1b0.zip
www-apps/radicale: remove old
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/38254 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'www-apps/radicale')
-rw-r--r--www-apps/radicale/files/radicale-r3.init.d27
-rw-r--r--www-apps/radicale/radicale-3.1.9.ebuild90
2 files changed, 0 insertions, 117 deletions
diff --git a/www-apps/radicale/files/radicale-r3.init.d b/www-apps/radicale/files/radicale-r3.init.d
deleted file mode 100644
index bb0cc5db08b0..000000000000
--- a/www-apps/radicale/files/radicale-r3.init.d
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-PIDFILE=/run/radicale.pid
-
-depend() {
- need localmount
-}
-
-start() {
- ebegin "Starting radicale"
- start-stop-daemon --start --quiet --background \
- --user radicale \
- --umask 0027 \
- --stderr-logger /usr/bin/logger \
- --pidfile ${PIDFILE} --make-pidfile \
- --exec /usr/bin/radicale
- eend $?
-}
-
-stop() {
- ebegin "Stopping radicale"
- start-stop-daemon --stop --quiet \
- --pidfile ${PIDFILE}
- eend $?
-}
diff --git a/www-apps/radicale/radicale-3.1.9.ebuild b/www-apps/radicale/radicale-3.1.9.ebuild
deleted file mode 100644
index 7c3557675f25..000000000000
--- a/www-apps/radicale/radicale-3.1.9.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 systemd
-
-MY_P=${P^}
-DESCRIPTION="A simple CalDAV calendar server"
-HOMEPAGE="https://radicale.org/"
-SRC_URI="
- https://github.com/Kozea/Radicale/archive/refs/tags/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-RDEPEND="
- >=acct-user/radicale-0-r2
- acct-group/radicale
- dev-python/bcrypt[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/vobject[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-apps/util-linux
-"
-
-BDEPEND="
- test? (
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/waitress[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-RDIR=/var/lib/"${PN}"
-
-DOCS=( DOCUMENTATION.md CHANGELOG.md )
-
-python_test() {
- epytest -o addopts= radicale/tests/
-}
-
-python_install_all() {
- rm README* || die
- # init file
- newinitd "${FILESDIR}"/radicale-r3.init.d radicale
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- # directories
- keepdir "${RDIR}"
- fperms 0750 "${RDIR}"
- fowners "${PN}:${PN}" "${RDIR}"
-
- # config file
- insinto /etc/"${PN}"
- doins config
-
- # fcgi and wsgi files
- exeinto /usr/share/"${PN}"
- doexe radicale.wsgi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- local _erdir="${EROOT}${RDIR}"
-
- einfo "A sample WSGI script has been put into ${EROOT}/usr/share/${PN}."
- einfo "You will also find there an example FastCGI script."
- if [[ $(stat --format="%U:%G:%a" "${_erdir}") != "${PN}:${PN}:750" ]]
- then
- ewarn ""
- ewarn "Unsafe file permissions detected on ${_erdir}."
- ewarn "This probably comes from an earlier version of this ebuild."
- ewarn "To fix run:"
- ewarn "# \`chown -R ${PN}:${PN} ${_erdir}\`"
- ewarn "# \`chmod 0750 ${_erdir}\`"
- ewarn "# \`chmod -R o= ${_erdir}\`"
- fi
-}