summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-07 22:05:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-07 22:05:26 +0300
commit098174e77d2640872404beb286d5e2c44077f7f5 (patch)
tree20570095ba9958189e8fbb901e3b96e56f4ee720 /sys-process/iotop-c
parentapp-editors/vscode: drop 1.79.0, 1.79.1 (diff)
downloadgentoo-098174e77d2640872404beb286d5e2c44077f7f5.tar.gz
gentoo-098174e77d2640872404beb286d5e2c44077f7f5.tar.bz2
gentoo-098174e77d2640872404beb286d5e2c44077f7f5.zip
sys-process/iotop-c: fix extra _FORTIFY_SOURCE
Closes: https://bugs.gentoo.org/898166 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process/iotop-c')
-rw-r--r--sys-process/iotop-c/iotop-c-1.23-r1.ebuild (renamed from sys-process/iotop-c/iotop-c-1.23.ebuild)5
-rw-r--r--sys-process/iotop-c/iotop-c-9999.ebuild7
2 files changed, 11 insertions, 1 deletions
diff --git a/sys-process/iotop-c/iotop-c-1.23.ebuild b/sys-process/iotop-c/iotop-c-1.23-r1.ebuild
index 01595c683cbc..c401c231d083 100644
--- a/sys-process/iotop-c/iotop-c-1.23.ebuild
+++ b/sys-process/iotop-c/iotop-c-1.23-r1.ebuild
@@ -25,6 +25,11 @@ FILECAPS=(
cap_net_admin=eip usr/bin/iotop
)
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
src_compile() {
emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
}
diff --git a/sys-process/iotop-c/iotop-c-9999.ebuild b/sys-process/iotop-c/iotop-c-9999.ebuild
index b05952298d1d..47a5c48a0a0e 100644
--- a/sys-process/iotop-c/iotop-c-9999.ebuild
+++ b/sys-process/iotop-c/iotop-c-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,6 +23,11 @@ FILECAPS=(
cap_net_admin=eip usr/bin/iotop
)
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
src_compile() {
emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
}