summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-10-25 08:17:58 -0400
committerMike Pagano <mpagano@gentoo.org>2023-10-25 08:17:58 -0400
commite3ba395bb1397b220e7ae3a66245e36bf63669ab (patch)
treed45347dca54cf1c01cf4fb16a7379ae1f7ad94e2 /sys-kernel
parentsys-kernel/gentoo-sources: add 5.10.199, TAR patch and gcc 14 patch (diff)
downloadgentoo-e3ba395bb1397b220e7ae3a66245e36bf63669ab.tar.gz
gentoo-e3ba395bb1397b220e7ae3a66245e36bf63669ab.tar.bz2
gentoo-e3ba395bb1397b220e7ae3a66245e36bf63669ab.zip
sys-kernel/gentoo-sources: add 5.15.136, kbuild patch
kbuild: Use CRC32 and a 1MiB dictionary for XZ compressed modules Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.15.136.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.15.136.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.15.136.ebuild
new file mode 100644
index 000000000000..e4efd391c60d
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.15.136.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="142"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}