summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 16:16:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:30 +0100
commit9051ecef58da9fb913bfa241112eff4d000a7259 (patch)
tree103031256a9f65792aad5eede693f4dbbfb5755e /sys-devel/clang-runtime
parentsys-libs/libomp: Add 15.x live ebuild (diff)
downloadgentoo-9051ecef58da9fb913bfa241112eff4d000a7259.tar.gz
gentoo-9051ecef58da9fb913bfa241112eff4d000a7259.tar.bz2
gentoo-9051ecef58da9fb913bfa241112eff4d000a7259.zip
sys-devel/clang-runtime: Add 15.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
new file mode 100644
index 000000000000..23ad83f3671d
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"