summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-13 11:31:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-13 21:26:07 +0200
commitdf60326ebf96acc478d1d0aeb9eb5b9ef2529896 (patch)
tree5b63967fdacb0841e5f18242642287db124fab85 /sys-apps
parentdev-python/tifffile: add 2023.8.12 (diff)
downloadgentoo-df60326ebf96acc478d1d0aeb9eb5b9ef2529896.tar.gz
gentoo-df60326ebf96acc478d1d0aeb9eb5b9ef2529896.tar.bz2
gentoo-df60326ebf96acc478d1d0aeb9eb5b9ef2529896.zip
sys-apps/system-monitoring-center: bump to 2.21.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.21.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index 68d8e7327d5f..fd31790e6131 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -2,3 +2,4 @@ DIST system-monitoring-center-2.17.2.tar.gz 534153 BLAKE2B af347f35e4e29e0e8a075
DIST system-monitoring-center-2.18.3.tar.gz 1496729 BLAKE2B f9ea49d9bc04b6f395b6a19c4f4a75ad047fcb53e4d766b2a93acac5a05d9bbde89d206d55155fe07a6f52bec04c604bcdaeb9ac37ad4d91da0a2c8e0ae5f98d SHA512 ebe47064647a8089400e1697813e673ce0f8bcf7dde3e79a76670edfd65eea7b59d067544e61dc61c10422e46403174ee6042191e93a09adbcc0076d576372de
DIST system-monitoring-center-2.20.2.tar.gz 1503080 BLAKE2B f7be7678b6ba91bba2654bb189ae46775182ae7f9fc349d2259678438597dadb1553aedf461356bf84ff16245263d3d41eb876ec35793fdaf307d404a9491bce SHA512 69df00396bbfea7a08ee067ba32d7163e2ded3fd9c4260fe71fb2b060d91c2e3b7e3aeb3a8d5731e8f1948add59edafedfb3cce1555f599d8e9a56235adc91a9
DIST system-monitoring-center-2.21.0.tar.gz 1508753 BLAKE2B f2ae964139ea36a48384aaea79d25d3f2d7dba040f379c766e266e34a3038ad82089a2de5d7cbfb8d686a0b3046cc49be0e6537b6667c0c60d48144f0395f769 SHA512 7c10f622013f0c4029262c94a46acebfc32062017d9896b789041a9e09f28d3c530f0d1ca47769794e621b1ad83f911613db406807ad5dc4b7b27defbc035f7f
+DIST system-monitoring-center-2.21.1.tar.gz 1505833 BLAKE2B a2270f20e745191eb72c299d2d4f9a28d5a06ec538813ed60afa628bc4cc053a5ca3e0a5daacc60008d46de55a03d7403e2dbec1f3d62fa67361661bc0101ace SHA512 acc3ea1623407aec703efdd8461a67bb858446b6dbcecfddbf26e0edea1c39ca0cd64d0f81d662340d540cf4fe855bcbc8eb20b48af7f2caea2e7b39169c8c53
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.21.1.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.21.1.ebuild
new file mode 100644
index 000000000000..0d57d2200134
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.21.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}