summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/kbd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/kbd/files')
-rw-r--r--sys-apps/kbd/files/kbd-1.15.5-loadkeys-parse.patch90
-rw-r--r--sys-apps/kbd/files/kbd-2.0.0-tests.patch34
-rw-r--r--sys-apps/kbd/files/kbd-2.0.1-big_endian.patch27
-rw-r--r--sys-apps/kbd/files/kbd-2.0.1-stdarg.patch43
4 files changed, 194 insertions, 0 deletions
diff --git a/sys-apps/kbd/files/kbd-1.15.5-loadkeys-parse.patch b/sys-apps/kbd/files/kbd-1.15.5-loadkeys-parse.patch
new file mode 100644
index 000000000000..c78a22780840
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-1.15.5-loadkeys-parse.patch
@@ -0,0 +1,90 @@
+https://bugs.gentoo.org/447440
+
+From 7e06e56157e8431d02e1377cdc44230944203d88 Mon Sep 17 00:00:00 2001
+From: Alexey Gladkov <gladkov.alexey@gmail.com>
+Date: Tue, 11 Dec 2012 14:24:44 +0400
+Subject: [PATCH] Fix regression in 16117ce6ab
+
+Signed-off-by: Alexey Gladkov <gladkov.alexey@gmail.com>
+---
+ src/loadkeys.analyze.l | 14 +++++++++-----
+ 1 file changed, 9 insertions(+), 5 deletions(-)
+
+diff --git a/src/loadkeys.analyze.l b/src/loadkeys.analyze.l
+index c18dcea..f817c78 100644
+--- a/src/loadkeys.analyze.l
++++ b/src/loadkeys.analyze.l
+@@ -307,8 +307,10 @@ To to|To|TO
+ char *s = xstrndup(yytext+1, strlen(yytext)-2);
+ /* use static pathname to store *s ? */
+ open_include(s);
+- yy_pop_state();
+- state_ptr--;
++ while (state_ptr > 0) {
++ yy_pop_state();
++ state_ptr--;
++ }
+ }
+ <INCLSTR>[^"]|\"\"|\"[^"\n]*{Eol} {
+ yyerror(_("expected filename between quotes"));
+@@ -323,7 +325,7 @@ To to|To|TO
+ }
+ {Eol} {
+ line_nr++;
+- if (state_ptr > 0) {
++ while (state_ptr > 0) {
+ yy_pop_state();
+ state_ptr--;
+ }
+@@ -428,8 +430,10 @@ To to|To|TO
+ }
+ <STR>\" {
+ *p = '\0';
+- yy_pop_state();
+- state_ptr--;
++ while (state_ptr > 0) {
++ yy_pop_state();
++ state_ptr--;
++ }
+ return(STRLITERAL);
+ }
+ . {
+--- a/src/loadkeys.analyze.c
++++ b/src/loadkeys.analyze.c
+@@ -1359,8 +1359,10 @@ YY_RULE_SETUP
+ char *s = xstrndup(yytext+1, strlen(yytext)-2);
+ /* use static pathname to store *s ? */
+ open_include(s);
+- yy_pop_state();
+- state_ptr--;
++ while (state_ptr > 0) {
++ yy_pop_state();
++ state_ptr--;
++ }
+ }
+ YY_BREAK
+ case 3:
+@@ -1393,7 +1395,7 @@ YY_RULE_SETUP
+ #line 324 "loadkeys.analyze.l"
+ {
+ line_nr++;
+- if (state_ptr > 0) {
++ while (state_ptr > 0) {
+ yy_pop_state();
+ state_ptr--;
+ }
+@@ -1670,8 +1670,10 @@ YY_RULE_SETUP
+ #line 429 "loadkeys.analyze.l"
+ {
+ *p = '\0';
+- yy_pop_state();
+- state_ptr--;
++ while (state_ptr > 0) {
++ yy_pop_state();
++ state_ptr--;
++ }
+ return(STRLITERAL);
+ }
+ YY_BREAK
+--
+1.8.0.2
diff --git a/sys-apps/kbd/files/kbd-2.0.0-tests.patch b/sys-apps/kbd/files/kbd-2.0.0-tests.patch
new file mode 100644
index 000000000000..6a1c7ea851e3
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-2.0.0-tests.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/485116
+http://lists.altlinux.org/pipermail/kbd/2015-July/000558.html
+
+--- configure.ac
++++ configure.ac
+@@ -11,7 +11,13 @@
+ AC_CONFIG_SRCDIR([src/loadkeys.c])
+ AC_CONFIG_HEADERS(config.h)
+
+-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
++AC_ARG_ENABLE(tests,
++ AS_HELP_STRING(--enable-tests, [build tests]),
++ [BUILD_TESTS=$enableval],[BUILD_TESTS=no])
++AM_CONDITIONAL(BUILD_TESTS, test "$BUILD_TESTS" = "yes")
++if test "$BUILD_TESTS" = "yes"; then
++ PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
++fi
+
+ m4_ifndef([AM_SILENT_RULES], [m4_define([AM_SILENT_RULES],[])])
+ AM_SILENT_RULES([yes])
+--- Makefile.am
++++ Makefile.am
+@@ -8,7 +8,10 @@
+ CREDITS \
+ contrib docs rc
+
+-SUBDIRS = src data po tests docs
++SUBDIRS = src data po docs
++if BUILD_TESTS
++SUBDIRS += tests
++endif
+
+ kbd-$(VERSION).tar.xz:
+ make distcheck
diff --git a/sys-apps/kbd/files/kbd-2.0.1-big_endian.patch b/sys-apps/kbd/files/kbd-2.0.1-big_endian.patch
new file mode 100644
index 000000000000..f69b7f9c811a
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-2.0.1-big_endian.patch
@@ -0,0 +1,27 @@
+From 363185b72ccb5279fa950a378ebd93c082078d39 Mon Sep 17 00:00:00 2001
+From: Aaro Koskinen <aaro.koskinen@iki.fi>
+Date: Sat, 15 Mar 2014 01:32:56 +0200
+Subject: libkeymap: fix kmap on big-endian machines
+
+Currently "loadkeys" does not work properly (no keys are ever changed)
+on big-endian machines (e.g. SPARC and other classic hardware)
+due to incorrect typing. The patch fixes this.
+
+Signed-off-by: Aaro Koskinen <aaro.koskinen@iki.fi>
+
+diff --git a/src/libkeymap/kmap.c b/src/libkeymap/kmap.c
+index e529136..85a3bb3 100644
+--- a/src/libkeymap/kmap.c
++++ b/src/libkeymap/kmap.c
+@@ -37,7 +37,7 @@ int
+ lk_key_exists(struct lk_ctx *ctx, unsigned int k_table, unsigned int k_index)
+ {
+ struct lk_array *map;
+- u_short *key;
++ unsigned int *key;
+
+ map = lk_array_get_ptr(ctx->keymap, k_table);
+ if (!map) {
+--
+cgit v0.10.1
+
diff --git a/sys-apps/kbd/files/kbd-2.0.1-stdarg.patch b/sys-apps/kbd/files/kbd-2.0.1-stdarg.patch
new file mode 100644
index 000000000000..b325af4b1d6a
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-2.0.1-stdarg.patch
@@ -0,0 +1,43 @@
+From 7955ccd650dc3235df3bf6333222c2811dd43141 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 6 Jan 2014 10:27:23 -0500
+Subject: [PATCH] libkeymap: include stdarg.h where used
+
+Some of these headers use va_list but don't include stdarg.h for it.
+
+Reported-by: Anthony Basile <blueness@gentoo.org>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ src/libkeymap/contextP.h | 2 ++
+ src/libkeymap/keymap/common.h | 2 ++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/src/libkeymap/contextP.h b/src/libkeymap/contextP.h
+index e3798e3..8ee3fab 100644
+--- a/src/libkeymap/contextP.h
++++ b/src/libkeymap/contextP.h
+@@ -1,6 +1,8 @@
+ #ifndef LK_CONTEXTP_H
+ #define LK_CONTEXTP_H
+
++#include <stdarg.h>
++
+ #include "keymap.h"
+
+ /**
+diff --git a/src/libkeymap/keymap/common.h b/src/libkeymap/keymap/common.h
+index 6b9cead..987b564 100644
+--- a/src/libkeymap/keymap/common.h
++++ b/src/libkeymap/keymap/common.h
+@@ -6,6 +6,8 @@
+ #ifndef LK_COMMON_H
+ #define LK_COMMON_H
+
++#include <stdarg.h>
++
+ #include <keymap/context.h>
+
+ /** Initializes the structures necessary to read and/or parse keymap.
+--
+1.8.4.3
+