summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/dstat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/dstat')
-rw-r--r--sys-apps/dstat/Manifest2
-rw-r--r--sys-apps/dstat/dstat-0.6.9-r1.ebuild44
-rw-r--r--sys-apps/dstat/dstat-0.7.2-r1.ebuild48
-rw-r--r--sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch15
-rw-r--r--sys-apps/dstat/metadata.xml20
5 files changed, 129 insertions, 0 deletions
diff --git a/sys-apps/dstat/Manifest b/sys-apps/dstat/Manifest
new file mode 100644
index 000000000000..472eb7f68f95
--- /dev/null
+++ b/sys-apps/dstat/Manifest
@@ -0,0 +1,2 @@
+DIST dstat-0.6.9.tar.bz2 74060 SHA256 edb2c17d081ee2b0b4fc2c57c2ed6dc36628853abd76c838026e99b3d1ea897c
+DIST dstat-0.7.2.tar.bz2 85870 SHA256 34a986d9d7c028bd9dcb6b2ef1c740f7220de5c9cf976870a2b62aca23b33bae SHA512 276447c0f5492e4d2ac78f9f5b1d08e3565d26d02a7e6a22ef70f77b20f84d2b9ba806212860886139d401e4dfc2453c0dbc9ed82398ddec0ee75f5999080624 WHIRLPOOL 1f263026b137ac3f6bfb70d8840a52769505a6c55301607a4a6afae36fd084326922bf3f8edf5399df004a3d8f7dce165b5613e6729dc2944e8e6bf1674d2cb4
diff --git a/sys-apps/dstat/dstat-0.6.9-r1.ebuild b/sys-apps/dstat/dstat-0.6.9-r1.ebuild
new file mode 100644
index 000000000000..5f129b427b09
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.6.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit python eutils
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ~ppc ~ppc64 sparc x86"
+IUSE=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2009-3894.patch # 293497
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc \
+ AUTHORS ChangeLog README TODO \
+ examples/{mstat,read}.py docs/*.txt
+ dohtml docs/*.html
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}
diff --git a/sys-apps/dstat/dstat-0.7.2-r1.ebuild b/sys-apps/dstat/dstat-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..3f93d849ceff
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit python eutils
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="wifi"
+
+RDEPEND="wifi? ( net-wireless/python-wifi )"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ python_convert_shebangs 2 "${ED}usr/bin/dstat"
+
+ dodoc \
+ AUTHORS ChangeLog README TODO \
+ examples/{mstat,read}.py docs/*.txt
+ dohtml docs/*.html
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}
diff --git a/sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch b/sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch
new file mode 100644
index 000000000000..042552b9a3bd
--- /dev/null
+++ b/sys-apps/dstat/files/dstat-0.6.9-CVE-2009-3894.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=293497
+
+Index: dstat-0.6.9/dstat
+===================================================================
+--- dstat-0.6.9.orig/dstat
++++ dstat-0.6.9/dstat
+@@ -28,8 +28,6 @@ try:
+ inspath('/usr/local/share/dstat/')
+ inspath('/usr/share/dstat/')
+ inspath(os.path.abspath(os.path.dirname(sys.argv[0])) + '/plugins/') # binary path + /plugins/
+- inspath(os.getcwd() + '/plugins/') # current path + /plugins/
+- inspath(os.getcwd()) # current path
+ inspath(os.path.expanduser('~/.dstat/')) # home + /.dstat/
+ except KeyboardInterrupt, e:
+ pass
diff --git a/sys-apps/dstat/metadata.xml b/sys-apps/dstat/metadata.xml
new file mode 100644
index 000000000000..4903eb22ef7c
--- /dev/null
+++ b/sys-apps/dstat/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ </maintainer>
+ <longdescription>
+Dstat is a versatile replacement for vmstat, iostat and ifstat. Dstat overcomes
+some of the limitations and adds some extra features.
+
+Dstat allows you to view all of your system resources instantly, you can eg.
+compare disk usage in combination with interrupts from your IDE controller, or
+compare the network bandwidth numbers directly with the disk throughput (in the
+same interval).
+ </longdescription>
+ <use>
+ <flag name="wifi">Enable wireless network functions</flag>
+ </use>
+</pkgmetadata>