summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-17 23:43:28 +0100
committerSam James <sam@gentoo.org>2023-06-17 23:46:45 +0100
commit91caf8a690ae6df19f7287f2ee7c0790ca3a8150 (patch)
tree15311ab7b8e10e7ff48fe91e6e5e36529c995b70 /sys-apps/coreutils/coreutils-9999.ebuild
parentlinux-mod.eclass: Mark as deprecated in favor of linux-mod-r1.eclass (diff)
downloadgentoo-91caf8a690ae6df19f7287f2ee7c0790ca3a8150.tar.gz
gentoo-91caf8a690ae6df19f7287f2ee7c0790ca3a8150.tar.bz2
gentoo-91caf8a690ae6df19f7287f2ee7c0790ca3a8150.zip
sys-apps/coreutils: append-lfs-flags for alpha & friends
Thanks to matoro for investigating & reporting upstream. The gnulib autoconf machinery doesn't seem to realise right now that we need _F_O_B=64 on alpha at least for 64-bit ino_t. Bug: https://debbugs.gnu.org/64123 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/coreutils/coreutils-9999.ebuild')
-rw-r--r--sys-apps/coreutils/coreutils-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-apps/coreutils/coreutils-9999.ebuild b/sys-apps/coreutils/coreutils-9999.ebuild
index 6e3d435cba1d..3e4dc9a20eb0 100644
--- a/sys-apps/coreutils/coreutils-9999.ebuild
+++ b/sys-apps/coreutils/coreutils-9999.ebuild
@@ -23,7 +23,7 @@ if [[ ${PV} == 9999 ]] ; then
elif [[ ${PV} == *_p* ]] ; then
# Note: could put this in devspace, but if it's gone, we don't want
# it in tree anyway. It's just for testing.
- MY_SNAPSHOT="$(ver_cut 1-2).198-e68b1"
+ MY_SNAPSHOT="$(ver_cut 1-2).18-ffd62"
SRC_URI="https://www.pixelbeat.org/cu/coreutils-${MY_SNAPSHOT}.tar.xz -> ${P}.tar.xz"
SRC_URI+=" verify-sig? ( https://www.pixelbeat.org/cu/coreutils-${MY_SNAPSHOT}.tar.xz.sig -> ${P}.tar.xz.sig )"
S="${WORKDIR}"/${PN}-${MY_SNAPSHOT}
@@ -135,6 +135,10 @@ src_prepare() {
}
src_configure() {
+ # On alpha at least, gnulib (as of 9.3) can't seem to figure out we need
+ # _F_O_B=64: https://debbugs.gnu.org/64123
+ append-lfs-flags
+
local myconf=(
--with-packager="Gentoo"
--with-packager-version="${PVR} (p${PATCH_VER:-0})"