summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-21 22:21:08 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-21 22:21:08 +0100
commit5141be0b130e6706bee2869feaa8d7ee1c7cd3cf (patch)
tree378b1fd7603a162f9345e893a0cc4beaed2d713b /sci-libs/mpfi/mpfi-1.5.4.ebuild
parentgames-action/0verkill: Port to EAPI 7 (diff)
downloadgentoo-5141be0b130e6706bee2869feaa8d7ee1c7cd3cf.tar.gz
gentoo-5141be0b130e6706bee2869feaa8d7ee1c7cd3cf.tar.bz2
gentoo-5141be0b130e6706bee2869feaa8d7ee1c7cd3cf.zip
sci-libs/mpfi: bump to 1.5.4
Closes: https://bugs.gentoo.org/742560 Closes: https://github.com/gentoo/gentoo/pull/18327 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/mpfi/mpfi-1.5.4.ebuild')
-rw-r--r--sci-libs/mpfi/mpfi-1.5.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/mpfi/mpfi-1.5.4.ebuild b/sci-libs/mpfi/mpfi-1.5.4.ebuild
new file mode 100644
index 000000000000..7c513767c675
--- /dev/null
+++ b/sci-libs/mpfi/mpfi-1.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Multiple precision interval arithmetic library based on MPFR"
+HOMEPAGE="http://perso.ens-lyon.fr/nathalie.revol/software.html"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38111/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}