summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-09-10 00:53:22 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-30 11:17:21 +0200
commit2bffa516e1cd76320e55beea595d58c0b81c1106 (patch)
tree5164728c6f54cc5fbd8de315ff60b0e8c347f91e /sci-astronomy
parentsci-astronomy/calcmysky: drop 0.3.1 (diff)
downloadgentoo-2bffa516e1cd76320e55beea595d58c0b81c1106.tar.gz
gentoo-2bffa516e1cd76320e55beea595d58c0b81c1106.tar.bz2
gentoo-2bffa516e1cd76320e55beea595d58c0b81c1106.zip
sci-astronomy/calcmysky: add 0.3.3
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/38543 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/calcmysky/Manifest1
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.3.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
index 5acc7585e97c..f2cdee4701f1 100644
--- a/sci-astronomy/calcmysky/Manifest
+++ b/sci-astronomy/calcmysky/Manifest
@@ -1 +1,2 @@
DIST calcmysky-0.3.2.tar.gz 2166906 BLAKE2B c306b780b76ace936c373c4c554ed25fdfc3a507ebe34950634527c32deb59b99feb4d55e1b82150dd0611caf8835a1d178ec2a044a2ddf7b2ade604d6edb67a SHA512 a7f69b25c54be86ce179a118ca8a6d606e2c0fe7dc238b46620237e311dc5198a2aeb70e4885cc6553a26f7c38b78b5a338115a4606161fa249a806e891f88b6
+DIST calcmysky-0.3.3.tar.gz 2167016 BLAKE2B 93c1990a96ce4eb7c033ba3763aac2f347c5575c860522d99d7a0ab813d7bffbd678df32cbf3a249e8043e53560d355cb8656d9fce54df07aa9eb82cdfbdb0f7 SHA512 186281ad2aafac7006117cfb65d91c8053ab3caa9d4f67e5463471538bae40fd8fcc954c3fe9b9d2ca7bba4e6a1fdf8de33980469930cc23b1c21ee4b333917e
diff --git a/sci-astronomy/calcmysky/calcmysky-0.3.3.ebuild b/sci-astronomy/calcmysky/calcmysky-0.3.3.ebuild
new file mode 100644
index 000000000000..bd1d665e6e80
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.3.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/15"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}