summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-23 05:43:31 +0100
committerSam James <sam@gentoo.org>2023-04-23 05:45:55 +0100
commitf943aa6f3bb0d8ee29bdda71efc1e3e7f285153d (patch)
tree6cf92e3312727c731b13f1a65bf923b52a424879 /net-misc/sstp-client
parentnet-misc/sstp-client: update upstream metadata (diff)
downloadgentoo-f943aa6f3bb0d8ee29bdda71efc1e3e7f285153d.tar.gz
gentoo-f943aa6f3bb0d8ee29bdda71efc1e3e7f285153d.tar.bz2
gentoo-f943aa6f3bb0d8ee29bdda71efc1e3e7f285153d.zip
net-misc/sstp-client: fix compat. w/ ppp-2.5.0
Closes: https://bugs.gentoo.org/904846 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/sstp-client')
-rw-r--r--net-misc/sstp-client/Manifest1
-rw-r--r--net-misc/sstp-client/sstp-client-1.0.18-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/sstp-client/Manifest b/net-misc/sstp-client/Manifest
index c04331a85465..431ae0560518 100644
--- a/net-misc/sstp-client/Manifest
+++ b/net-misc/sstp-client/Manifest
@@ -1,2 +1,3 @@
DIST sstp-client-1.0.17.tar.gz 482831 BLAKE2B d19c752b3f061401f89eb46bd52091e3ab0a3c931c6646a55c1ee0e6dd7e9c501fba14b7c870a2514cb72fb0fd1d8bc89538562d4d99b9d58a081e0917734f5d SHA512 eff18eb894b2c96d46315b5ac7530fe50e8dd6e6c29ea946cd0e7c05c56416e85088fc65650fb77c05e3a747cb0b4e3575af5457515d240161027910abae9775
+DIST sstp-client-1.0.18-ppp-2.5.0.patch.xz 6564 BLAKE2B 97c5c1fc9d844e0845d2fff27bcfeb18834b1b007a14b2aa5ea1dad9af75b8bdb195d2469eb924466bfa68b9b7887aab2ddbe1208cb973c57232005e0b4977a1 SHA512 734d044eb956664a91cd045de5aa8f3f9730fb49eba816fb5a0decc19d47f0a00b2285aefd2735efd5285f68a93768b8b51ed9c557131a4ee25bb814f793ddc3
DIST sstp-client-1.0.18.tar.gz 477886 BLAKE2B 3a2929a5245a703c36b9bf6c17b7f65d911446a8a44b95894fd990ccf5ad01a98e4b5e843681e4643ff4b28a57de359a98ef42f9bb378d52c6829297970399b6 SHA512 e0dd0fe57b65c2001737222159e58b11177a8f1cb64564e520fad2199c0581d0550a00f49c921be74039dec59062233b4716f8b624a0e4cb48bdf8df9272f93c
diff --git a/net-misc/sstp-client/sstp-client-1.0.18-r1.ebuild b/net-misc/sstp-client/sstp-client-1.0.18-r1.ebuild
new file mode 100644
index 000000000000..134d2c5ee206
--- /dev/null
+++ b/net-misc/sstp-client/sstp-client-1.0.18-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Client implementation of Secure Socket Tunneling Protocol (SSTP)"
+HOMEPAGE="https://sstp-client.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sstp-client/${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-ppp-2.5.0.patch.xz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static"
+
+DEPEND="dev-libs/libevent:=
+ dev-libs/openssl:=
+ net-dialup/ppp:="
+RDEPEND="${DEPEND}
+ acct-group/sstpc
+ acct-user/sstpc"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK"
+
+DOCS=( AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.12-remove-network-test.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-example.patch"
+
+ "${FILESDIR}/${PN}-1.0.18-includes.patch"
+ "${WORKDIR}/${P}-ppp-2.5.0.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local PPPD_VER="$(best_version net-dialup/ppp)"
+ # Reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER#*/*-}
+ # Main version without beta/pre/patch/revision
+ PPPD_VER=${PPPD_VER%%[_-]*}
+
+ local myeconfargs=(
+ --enable-ppp-plugin
+ --enable-group=sstpc
+ --enable-user=sstpc
+ --with-pppd-plugin-dir="/usr/$(get_libdir)/pppd/${PPPD_VER}"
+ --with-runtime-dir="/run/sstpc"
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}