summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-08-26 13:49:37 -0400
committerMike Gilbert <floppym@gentoo.org>2020-08-26 13:49:55 -0400
commit3c6b2db93a64564c572eceed7ca627b062c2aa5d (patch)
treeb2b6944d65ae30b2eec4afd25b21f46d47942eb2 /net-ftp/tftp-hpa
parentnet-ftp/tftp-hpa: bump EAPI and split the package (diff)
downloadgentoo-3c6b2db93a64564c572eceed7ca627b062c2aa5d.tar.gz
gentoo-3c6b2db93a64564c572eceed7ca627b062c2aa5d.tar.bz2
gentoo-3c6b2db93a64564c572eceed7ca627b062c2aa5d.zip
net-ftp/tftp-hpa: several fixes
Fix dependencies. Add blocker on net-misc/iputils[tftpd]. Apply patches correctly. Use an array in src_configure. Prevent automagic dep on libbsd for bsd_signal(). Install man page. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-ftp/tftp-hpa')
-rw-r--r--net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild b/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild
index 239a1184ef6b..3381ec42a76b 100644
--- a/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild
+++ b/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild
@@ -14,33 +14,35 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
IUSE="ipv6 readline selinux tcpd +client +server"
-CDEPEND="
+DEPEND="
readline? ( sys-libs/readline:0= )
tcpd? ( sys-apps/tcp-wrappers )
- "
+"
-DEPEND="${CDEPEND}
- app-arch/xz-utils
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tftp )
!net-ftp/atftp
- !net-ftp/uftpd"
-
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-tftp )"
+ !net-ftp/uftpd
+ server? ( !net-misc/iputils[tftpd(+)] )
+"
PATCHES=(
"${FILESDIR}"/tftp-hpa-5.2-gcc-10.patch
)
src_prepare() {
- eapply_user
+ default
sed -i "/^AR/s:ar:$(tc-getAR):" MCONFIG.in || die
}
src_configure() {
- econf \
- $(use_with ipv6) \
- $(use_with tcpd tcpwrappers) \
+ local myconf=(
+ ac_cv_search_bsd_signal=no
+ $(use_with ipv6)
+ $(use_with tcpd tcpwrappers)
$(use_with readline)
+ )
+ econf "${myconf[@]}"
}
src_compile() {
@@ -64,8 +66,6 @@ src_install() {
if use server; then
emake INSTALLROOT="${D}" -C tftpd install
- rm "${ED}"/usr/share/man/man8/tftpd.8 || die
-
newconfd "${FILESDIR}"/in.tftpd.confd-0.44 in.tftpd
newinitd "${FILESDIR}"/in.tftpd.rc6 in.tftpd