summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJoakim Tjernlund <Joakim.Tjernlund@infinera.com>2022-11-17 10:04:25 +0100
committerSam James <sam@gentoo.org>2022-11-24 09:50:24 +0000
commit72b1e774c4f1559b276f6441b1288b6bb0d9c3a0 (patch)
tree6f7e689b0ab58e7391bf227c6654c628b7ef16e0 /net-fs
parentapp-misc/delay: fix build w/ clang 16 (diff)
downloadgentoo-72b1e774c4f1559b276f6441b1288b6bb0d9c3a0.tar.gz
gentoo-72b1e774c4f1559b276f6441b1288b6bb0d9c3a0.tar.bz2
gentoo-72b1e774c4f1559b276f6441b1288b6bb0d9c3a0.zip
net-fs/samba: Make smbspool_krb5_wrapper accessible to root only
For CUPS to exec an plugin as root, group and others must not have privs. Closes: https://bugs.gentoo.org/880739 Signed-off-by: Joakim Tjernlund <Joakim.Tjernlund@infinera.com> Closes: https://github.com/gentoo/gentoo/pull/28307 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-4.15.12-r2.ebuild (renamed from net-fs/samba/samba-4.15.12-r1.ebuild)2
-rw-r--r--net-fs/samba/samba-4.16.7-r2.ebuild (renamed from net-fs/samba/samba-4.16.7-r1.ebuild)2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-fs/samba/samba-4.15.12-r1.ebuild b/net-fs/samba/samba-4.15.12-r2.ebuild
index 9d2737f68680..2b804ec1862d 100644
--- a/net-fs/samba/samba-4.15.12-r1.ebuild
+++ b/net-fs/samba/samba-4.15.12-r2.ebuild
@@ -266,6 +266,8 @@ multilib_src_install() {
# Make all .so files executable
find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
+ # smbspool_krb5_wrapper must only be accessible to root, bug #880739
+ find "${ED}" -type f -name "smbspool_krb5_wrapper" -exec chmod go-rwx {} + || die
if multilib_is_native_abi ; then
# install ldap schema for server (bug #491002)
diff --git a/net-fs/samba/samba-4.16.7-r1.ebuild b/net-fs/samba/samba-4.16.7-r2.ebuild
index 36cf60e8eed0..81857fb18f5b 100644
--- a/net-fs/samba/samba-4.16.7-r1.ebuild
+++ b/net-fs/samba/samba-4.16.7-r2.ebuild
@@ -307,6 +307,8 @@ multilib_src_install() {
# Make all .so files executable
find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
+ # smbspool_krb5_wrapper must only be accessible to root, bug #880739
+ find "${ED}" -type f -name "smbspool_krb5_wrapper" -exec chmod go-rwx {} + || die
if multilib_is_native_abi ; then
# Install ldap schema for server (bug #491002)