summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndie Verbus <andieverbus@gmail.com>2023-04-05 09:17:45 -0400
committerSam James <sam@gentoo.org>2023-04-25 22:27:51 +0100
commit2d4842f93bbf405f1a260fca8fa838c5a992e307 (patch)
tree5ce1a0045c8b9ed14749ec185d848ea550a7372c /media-sound
parentmedia-sound/supercollider: add 3.13.0 (diff)
downloadgentoo-2d4842f93bbf405f1a260fca8fa838c5a992e307.tar.gz
gentoo-2d4842f93bbf405f1a260fca8fa838c5a992e307.tar.bz2
gentoo-2d4842f93bbf405f1a260fca8fa838c5a992e307.zip
media-sound/supercollider: drop 3.11.2 and unneeded patches
This version no longer compiles with the sndfile USE flag, which is a pretty necessary component Signed-off-by: Andie Verbus <andieverbus@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/supercollider/Manifest1
-rw-r--r--media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch25
-rw-r--r--media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch39
-rw-r--r--media-sound/supercollider/files/supercollider-3.11.2-fewer-qt-deps.patch129
-rw-r--r--media-sound/supercollider/files/supercollider-3.11.2-fix-libscsynth-linker-issue.patch299
-rw-r--r--media-sound/supercollider/supercollider-3.11.2.ebuild137
6 files changed, 0 insertions, 630 deletions
diff --git a/media-sound/supercollider/Manifest b/media-sound/supercollider/Manifest
index cf73948e1081..4436653080aa 100644
--- a/media-sound/supercollider/Manifest
+++ b/media-sound/supercollider/Manifest
@@ -1,2 +1 @@
-DIST SuperCollider-3.11.2-Source.tar.bz2 18130954 BLAKE2B 3713561e5ebee6dd4c08baa8aaaf4a422ab983480c76b2176373ce3cd080128f9392b50482e02dc82dce235e928d058c42722e0863dad9f6d2dd086894cd85da SHA512 636062c6acf8be43260632287b587f167352079c4e86ede34d1c6056180bfdb3ae50d6a3ff4f349327a3ab6af0eb01ac503d6b22667b4799dfcddd9c6489a23c
DIST SuperCollider-3.13.0-Source.tar.bz2 18685091 BLAKE2B a5e57a17f93e40848b2044ee0791179f857d144eabb7f4d74580b2eebd49a31d6ec671a0526236c5b906aadeb455e5a7ad18cacb79ed214076d6bceca39ea2ae SHA512 a60a128f7646f077f91adae666fa4014529aa9df78cf0dfe5d68c9bd6447f008af7da2970b8736f3f29d0adbaf67bce680a8201fcbe7e1aba29c3499a57f89cd
diff --git a/media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch b/media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch
deleted file mode 100644
index 66a765a8b9ea..000000000000
--- a/media-sound/supercollider/files/supercollider-3.10.2-no-ccache.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-disabled the use of ccache, to prevent FTBFS; as the compilation is done once
-it has no backdraws to make the debian package.
-Index: supercollider/CMakeLists.txt
-===================================================================
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,12 +150,12 @@ add_definitions(-DBOOST_CHRONO_HEADER_ON
- #############################################
- # Detect CCache
-
--find_program(CCacheExectuable ccache)
--if( CCacheExectuable )
-- # only used with >=cmake-3.4
-- set( CMAKE_C_COMPILER_LAUNCHER "${CCacheExectuable}" )
-- set( CMAKE_CXX_COMPILER_LAUNCHER "${CCacheExectuable}" )
--endif()
-+## find_program(CCacheExecutable ccache)
-+## if( CCacheExecutable )
-+## # only used with >=cmake-3.4
-+## set( CMAKE_C_COMPILER_LAUNCHER "${CCacheExecutable}" )
-+## set( CMAKE_CXX_COMPILER_LAUNCHER "${CCacheExecutable}" )
-+## endif()
-
- #############################################
- # Options
diff --git a/media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch b/media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch
deleted file mode 100644
index 1e1ca8b7e195..000000000000
--- a/media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From cc873049ff9249a33567e4cbcdeffeb6806a30d6 Mon Sep 17 00:00:00 2001
-From: brianlheim <self@brianlheim.com>
-Date: Tue, 25 Aug 2020 17:14:29 -0500
-Subject: [PATCH] remove workarounds for old boost versions
-
-we don't need to support boost pre-1.70 anymore, and tcp::socket::executor_type was always the right typealias to use
----
- server/supernova/sc/sc_osc_handler.hpp | 10 +---------
- 1 file changed, 1 insertion(+), 9 deletions(-)
-
-diff --git a/server/supernova/sc/sc_osc_handler.hpp b/server/supernova/sc/sc_osc_handler.hpp
-index f17e99a557..676c94dbf1 100644
---- a/server/supernova/sc/sc_osc_handler.hpp
-+++ b/server/supernova/sc/sc_osc_handler.hpp
-@@ -234,11 +234,7 @@ class sc_osc_handler : private detail::network_thread, public sc_notify_observer
- class tcp_connection : public nova_endpoint {
- public:
- using pointer = std::shared_ptr<tcp_connection>;
--#if BOOST_VERSION >= 107000
-- using executor = boost::asio::executor;
--#else
-- using executor = boost::asio::io_context::executor_type;
--#endif
-+ using executor = tcp::socket::executor_type;
-
- static pointer create(const executor& executor) { return pointer(new tcp_connection(executor)); }
-
-@@ -249,11 +245,7 @@ class sc_osc_handler : private detail::network_thread, public sc_notify_observer
- bool operator==(tcp_connection const& rhs) const { return &rhs == this; }
-
- private:
--#if BOOST_VERSION >= 107000
- tcp_connection(const executor& executor): socket_(executor) {}
--#else
-- tcp_connection(const executor& executor): socket_(executor.context()) {}
--#endif
-
- void send(const char* data, size_t length) override final;
-
diff --git a/media-sound/supercollider/files/supercollider-3.11.2-fewer-qt-deps.patch b/media-sound/supercollider/files/supercollider-3.11.2-fewer-qt-deps.patch
deleted file mode 100644
index a156a105f875..000000000000
--- a/media-sound/supercollider/files/supercollider-3.11.2-fewer-qt-deps.patch
+++ /dev/null
@@ -1,129 +0,0 @@
-From 063f9a48300b0c1d0132f6e0448ca724ad9e7474 Mon Sep 17 00:00:00 2001
-From: Hector Martin <marcan@marcan.st>
-Date: Mon, 1 Jun 2020 18:43:08 +0900
-Subject: [PATCH] Remove spurious Qt dependencies
-
----
- QtCollider/CMakeLists.txt | 10 +++-------
- QtCollider/widgets/QcCanvas.h | 2 --
- README_LINUX.md | 6 +++---
- README_RASPBERRY_PI.md | 2 +-
- editors/sc-ide/CMakeLists.txt | 13 +++----------
- 5 files changed, 10 insertions(+), 23 deletions(-)
-
-diff --git a/QtCollider/CMakeLists.txt b/QtCollider/CMakeLists.txt
-index de38afb90..6b9437b9c 100644
---- a/QtCollider/CMakeLists.txt
-+++ b/QtCollider/CMakeLists.txt
-@@ -7,19 +7,15 @@ option(SC_USE_QTWEBENGINE "Build with Qt WebEngine." ON)
- set(
- QT_COMPONENTS
- Core
-- Widgets
-+ Gui
- Network
- PrintSupport
-- OpenGL
-- Quick
-- Qml
-- Sql
- Svg
-+ Widgets
- )
-
- set (QT_COLLIDER_LIBS
-- Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::PrintSupport
-- Qt5::Quick Qt5::Qml Qt5::Sql Qt5::OpenGL Qt5::Svg
-+ Qt5::Core Qt5::Gui Qt5::Network Qt5::PrintSupport Qt5::Svg Qt5::Widgets
- ${MATH_LIBRARY})
-
- if(SC_USE_QTWEBENGINE)
-diff --git a/QtCollider/widgets/QcCanvas.h b/QtCollider/widgets/QcCanvas.h
-index 3acb00fc2..ff230b813 100644
---- a/QtCollider/widgets/QcCanvas.h
-+++ b/QtCollider/widgets/QcCanvas.h
-@@ -28,9 +28,7 @@
- #include <QBasicTimer>
- #include <QTime>
- #include <QPalette>
--#include <QGLWidget>
-
--// using QcCanvasBase = QGLWidget;
- using QcCanvasBase = QWidget;
-
- class QcCanvas : public QcCanvasBase {
-diff --git a/README_LINUX.md b/README_LINUX.md
-index 0e9577637..7b728a9ba 100644
---- a/README_LINUX.md
-+++ b/README_LINUX.md
-@@ -78,7 +78,7 @@ Depending on your Debian flavor and version, your distribution's PPA may be stuc
-
- If this displays version 5.7 or later, installing Qt is easy:
-
-- sudo apt-get install qt5-default qt5-qmake qttools5-dev qttools5-dev-tools qtdeclarative5-dev qtwebengine5-dev libqt5svg5-dev libqt5websockets5-dev
-+ sudo apt-get install qt5-default qt5-qmake qttools5-dev qttools5-dev-tools qtwebengine5-dev libqt5svg5-dev libqt5websockets5-dev
-
- If you are on Ubuntu 14.04 (Trusty) or 16.04 (Xenial), check the next section. Otherwise, you will have to use the official Qt installer. Sorry.
-
-@@ -90,13 +90,13 @@ On Xenial:
-
- sudo apt-add-repository ppa:beineri/opt-qt-5.11.0-xenial
- sudo apt-get update
-- sudo apt-get install qt511base qt511location qt511declarative qt511tools qt511webchannel qt511xmlpatterns qt511svg qt511webengine qt511websockets
-+ sudo apt-get install qt511base qt511location qt511tools qt511webchannel qt511xmlpatterns qt511svg qt511webengine qt511websockets
-
- On Trusty, only Qt 5.10 and below are available:
-
- sudo apt-add-repository ppa:beineri/opt-qt-5.10.1-trusty
- sudo apt-get update
-- sudo apt-get install qt510base qt510location qt510declarative qt510tools qt510webchannel qt510xmlpatterns qt510svg qt510webengine qt510websockets
-+ sudo apt-get install qt510base qt510location qt510tools qt510webchannel qt510xmlpatterns qt510svg qt510webengine qt510websockets
-
- [Stephan Binner's Launchpad PPAs]: https://launchpad.net/~beineri
-
-diff --git a/README_RASPBERRY_PI.md b/README_RASPBERRY_PI.md
-index 0e89e26fc..7835fd25d 100644
---- a/README_RASPBERRY_PI.md
-+++ b/README_RASPBERRY_PI.md
-@@ -42,7 +42,7 @@ Install required libraries:
- # For GUI builds:
- sudo apt-get install libjack-jackd2-dev libsndfile1-dev libasound2-dev libavahi-client-dev \
- libreadline-dev libfftw3-dev libxt-dev libudev-dev libncurses5-dev cmake git qttools5-dev qttools5-dev-tools \
-- qtdeclarative5-dev libqt5svg5-dev qjackctl
-+ qtbase5-dev libqt5svg5-dev qjackctl
- # For GUI-less builds:
- sudo apt-get install libsamplerate0-dev libsndfile1-dev libasound2-dev libavahi-client-dev \
- libreadline-dev libfftw3-dev libudev-dev libncurses5-dev cmake git
-diff --git a/editors/sc-ide/CMakeLists.txt b/editors/sc-ide/CMakeLists.txt
-index 2ff4de774..5f9c1e64b 100644
---- a/editors/sc-ide/CMakeLists.txt
-+++ b/editors/sc-ide/CMakeLists.txt
-@@ -6,22 +6,15 @@ set(QT_IDE_COMPONENTS
- Concurrent
- Core
- LinguistTools
-- # OpenGL
-- PrintSupport
-- Qml
-- Quick
-- Sql
-+ Network
- Widgets
- )
-
- set(QT_IDE_LIBRARIES
- Qt5::Concurrent
- Qt5::Core
-- # Qt5::OpenGL
-- Qt5::PrintSupport
-- Qt5::Qml
-- Qt5::Quick
-- Qt5::Sql
-+ Qt5::Network
-+ Qt5::Widgets
- )
-
- if(SC_USE_QTWEBENGINE)
---
-2.26.2
-
diff --git a/media-sound/supercollider/files/supercollider-3.11.2-fix-libscsynth-linker-issue.patch b/media-sound/supercollider/files/supercollider-3.11.2-fix-libscsynth-linker-issue.patch
deleted file mode 100644
index d703b6073706..000000000000
--- a/media-sound/supercollider/files/supercollider-3.11.2-fix-libscsynth-linker-issue.patch
+++ /dev/null
@@ -1,299 +0,0 @@
-From 9563fb5e73425a2ee0370162178964cceb559d5d Mon Sep 17 00:00:00 2001
-From: David Runge <dave@sleepmap.de>
-Date: Mon, 16 Nov 2020 12:00:22 +0100
-Subject: [PATCH] Backport #5014 for 3.11.2
-
-Backport the linker error patches
-(https://github.com/supercollider/supercollider/pull/5014) for 3.11.2.
----
- common/SC_Apple.hpp | 14 ------
- common/SC_Apple.mm | 60 -------------------------
- common/SC_AppleEventLoop.hpp | 34 ++++++++++++++
- common/SC_AppleEventLoop.mm | 80 +++++++++++++++++++++++++++++++++
- common/SC_EventLoop.hpp | 3 +-
- server/scsynth/CMakeLists.txt | 8 +++-
- server/supernova/CMakeLists.txt | 9 +++-
- 7 files changed, 131 insertions(+), 77 deletions(-)
- create mode 100644 common/SC_AppleEventLoop.hpp
- create mode 100644 common/SC_AppleEventLoop.mm
-
-diff --git a/common/SC_Apple.hpp b/common/SC_Apple.hpp
-index 958d097f36..c7e53e9fcc 100644
---- a/common/SC_Apple.hpp
-+++ b/common/SC_Apple.hpp
-@@ -23,19 +23,5 @@ namespace SC { namespace Apple {
-
- void disableAppNap();
-
--namespace EventLoop {
--
--// Setup the main application. This function must be called in the
--// main thread and before any other calls to Cocoa methods.
--void setup();
--// Run the event loop. This function must be called in the main thread.
--// It blocks until the event loop finishes.
--void run();
--// Ask the event loop to stop and terminate the program.
--// This function can be called from any thread.
--void quit();
--
--} // EventLoop
--
- } // namespace Apple
- } // namespace SC
-diff --git a/common/SC_Apple.mm b/common/SC_Apple.mm
-index a4e10a66cd..dbb7ddbb7d 100644
---- a/common/SC_Apple.mm
-+++ b/common/SC_Apple.mm
-@@ -42,65 +42,5 @@ void disableAppNap() {
- }
- }
-
--namespace EventLoop {
--
--static std::atomic_bool g_running;
--
--void setup() {
-- // The following code would transform the process into a foreground application.
-- // For now it's the plugin's responsibility to do this (early or lazily)
-- // because we don't want to always show an icon in the docker.
-- // ProcessSerialNumber psn = { 0, kCurrentProcess };
-- // TransformProcessType(&psn, kProcessTransformToForegroundApplication);
--
-- // Create NSApplication
-- [NSApplication sharedApplication];
--}
--
--void run() {
--#if 0
-- // this doesn't work...
-- [NSApp run];
--#else
-- // Kudos to https://www.cocoawithlove.com/2009/01/demystifying-nsapplication-by.html
-- NSAutoreleasePool* pool = [[NSAutoreleasePool alloc] init];
--
-- [NSApp finishLaunching];
-- g_running = true;
--
-- while (g_running) {
-- [pool release];
-- pool = [[NSAutoreleasePool alloc] init];
-- NSEvent* event = [NSApp nextEventMatchingMask:NSAnyEventMask
-- untilDate:[NSDate distantFuture]
-- inMode:NSDefaultRunLoopMode
-- dequeue:YES];
-- if (event) {
-- [NSApp sendEvent:event];
-- [NSApp updateWindows];
-- }
-- }
-- [pool release];
--#endif
--}
--
--void quit() {
-- // break from event loop instead of [NSApp terminate:nil]
-- g_running = false;
-- // send dummy event to wake up event loop
-- NSEvent* event = [NSEvent otherEventWithType:NSApplicationDefined
-- location:NSMakePoint(0, 0)
-- modifierFlags:0
-- timestamp:0
-- windowNumber:0
-- context:nil
-- subtype:0
-- data1:0
-- data2:0];
-- [NSApp postEvent:event atStart:NO];
--}
--
--} // EventLoop
--
- } // namespace Apple
- } // namespace SC
-diff --git a/common/SC_AppleEventLoop.hpp b/common/SC_AppleEventLoop.hpp
-new file mode 100644
-index 0000000000..6f19bb2818
---- /dev/null
-+++ b/common/SC_AppleEventLoop.hpp
-@@ -0,0 +1,34 @@
-+/************************************************************************
-+ *
-+ * Copyright 2019 Christof Ressi <info@christofressi.com>
-+ *
-+ * This program is free software: you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License as published by
-+ * the Free Software Foundation, either version 2 of the License, or
-+ * (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
-+ *
-+ ************************************************************************/
-+
-+#pragma once
-+
-+namespace SC { namespace Apple { namespace EventLoop {
-+
-+// Setup the main application. This function must be called in the
-+// main thread and before any other calls to Cocoa methods.
-+void setup();
-+// Run the event loop. This function must be called in the main thread.
-+// It blocks until the event loop finishes.
-+void run();
-+// Ask the event loop to stop and terminate the program.
-+// This function can be called from any thread.
-+void quit();
-+
-+}}} // namespace SC::Apple::EventLoop
-diff --git a/common/SC_AppleEventLoop.mm b/common/SC_AppleEventLoop.mm
-new file mode 100644
-index 0000000000..cfcf42ddfe
---- /dev/null
-+++ b/common/SC_AppleEventLoop.mm
-@@ -0,0 +1,80 @@
-+/************************************************************************
-+ *
-+ * Copyright 2019 Christof Ressi <info@christofressi.com>
-+ *
-+ * This program is free software: you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License as published by
-+ * the Free Software Foundation, either version 2 of the License, or
-+ * (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
-+ *
-+ ************************************************************************/
-+
-+#include "SC_AppleEventLoop.hpp"
-+#include <atomic>
-+
-+#import <Cocoa/Cocoa.h>
-+
-+namespace SC { namespace Apple { namespace EventLoop {
-+
-+static std::atomic_bool g_running;
-+
-+void setup() {
-+ // The following code would transform the process into a foreground application.
-+ // For now it's the plugin's responsibility to do this (early or lazily)
-+ // because we don't want to always show an icon in the docker.
-+ // ProcessSerialNumber psn = { 0, kCurrentProcess };
-+ // TransformProcessType(&psn, kProcessTransformToForegroundApplication);
-+
-+ // Create NSApplication
-+ [NSApplication sharedApplication];
-+}
-+
-+void run() {
-+ // this doesn't work...
-+ // [NSApp run];
-+ // Kudos to https://www.cocoawithlove.com/2009/01/demystifying-nsapplication-by.html
-+ NSAutoreleasePool* pool = [[NSAutoreleasePool alloc] init];
-+
-+ [NSApp finishLaunching];
-+ g_running = true;
-+
-+ while (g_running) {
-+ [pool release];
-+ pool = [[NSAutoreleasePool alloc] init];
-+ NSEvent* event = [NSApp nextEventMatchingMask:NSAnyEventMask
-+ untilDate:[NSDate distantFuture]
-+ inMode:NSDefaultRunLoopMode
-+ dequeue:YES];
-+ if (event) {
-+ [NSApp sendEvent:event];
-+ [NSApp updateWindows];
-+ }
-+ }
-+ [pool release];
-+}
-+
-+void quit() {
-+ // break from event loop instead of [NSApp terminate:nil]
-+ g_running = false;
-+ // send dummy event to wake up event loop
-+ NSEvent* event = [NSEvent otherEventWithType:NSApplicationDefined
-+ location:NSMakePoint(0, 0)
-+ modifierFlags:0
-+ timestamp:0
-+ windowNumber:0
-+ context:nil
-+ subtype:0
-+ data1:0
-+ data2:0];
-+ [NSApp postEvent:event atStart:NO];
-+}
-+
-+}}} // namespace SC::Apple::EventLoop
-diff --git a/common/SC_EventLoop.hpp b/common/SC_EventLoop.hpp
-index 1d62b4de89..6e58208cc0 100644
---- a/common/SC_EventLoop.hpp
-+++ b/common/SC_EventLoop.hpp
-@@ -2,7 +2,7 @@
-
- #include <functional>
- #ifdef __APPLE__
--# include "SC_Apple.hpp"
-+# include "SC_AppleEventLoop.hpp"
- # include <thread>
- #endif
-
-@@ -21,6 +21,7 @@ class EventLoop {
- SC::Apple::EventLoop::setup();
- #endif
- }
-+
- // Run the event loop until 'waitFunction' returns.
- static void run(std::function<void()> waitFunction) {
- #ifdef __APPLE__
-diff --git a/server/scsynth/CMakeLists.txt b/server/scsynth/CMakeLists.txt
-index fa8daf12aa..c60ae72ffc 100644
---- a/server/scsynth/CMakeLists.txt
-+++ b/server/scsynth/CMakeLists.txt
-@@ -230,7 +230,13 @@ if(CMAKE_SYSTEM_NAME MATCHES "Linux")
- target_link_libraries(libscsynth rt)
- endif()
-
--add_executable(scsynth scsynth_main.cpp)
-+add_executable(scsynth
-+ scsynth_main.cpp
-+
-+ # these files contain code only used in main()
-+ ${CMAKE_SOURCE_DIR}/common/SC_ServerBootDelayWarning.cpp
-+ $<$<BOOL:${APPLE}>: ${CMAKE_SOURCE_DIR}/common/SC_AppleEventLoop.mm >
-+ )
- target_link_libraries(scsynth libscsynth)
-
- if (PTHREADS_FOUND)
-diff --git a/server/supernova/CMakeLists.txt b/server/supernova/CMakeLists.txt
-index 923a3aa4e4..ce8388e475 100644
---- a/server/supernova/CMakeLists.txt
-+++ b/server/supernova/CMakeLists.txt
-@@ -182,7 +182,14 @@ if(WIN32)
- endif()
-
-
--add_executable(supernova server/main.cpp ${supernova_headers})
-+add_executable(supernova
-+ server/main.cpp
-+ ${supernova_headers}
-+
-+ # these files contain code only used in main()
-+ ${CMAKE_SOURCE_DIR}/common/SC_ServerBootDelayWarning.cpp
-+ $<$<BOOL:${APPLE}>: ${CMAKE_SOURCE_DIR}/common/SC_AppleEventLoop.mm >
-+ )
- target_link_libraries(supernova libsupernova)
-
- if(WIN32)
diff --git a/media-sound/supercollider/supercollider-3.11.2.ebuild b/media-sound/supercollider/supercollider-3.11.2.ebuild
deleted file mode 100644
index cd65768c24e3..000000000000
--- a/media-sound/supercollider/supercollider-3.11.2.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic readme.gentoo-r1 xdg-utils
-
-DESCRIPTION="Environment and programming language for real time audio synthesis"
-HOMEPAGE="https://supercollider.github.io/"
-SRC_URI="https://github.com/supercollider/supercollider/releases/download/Version-${PV}/SuperCollider-${PV}-Source.tar.bz2"
-
-LICENSE="GPL-2 gpl3? ( GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2 debug emacs +fftw gedit +gpl3 jack qt5 server +sndfile static-libs vim webengine X zeroconf"
-
-REQUIRED_USE="
- qt5? ( X )
- webengine? ( qt5 )
-"
-
-BDEPEND="
- virtual/pkgconfig
- qt5? ( dev-qt/linguist-tools:5 )
-"
-RDEPEND="
- dev-cpp/yaml-cpp:=
- dev-libs/boost:=
- media-libs/alsa-lib
- sys-libs/readline:0=
- virtual/libudev:=
- fftw? ( sci-libs/fftw:3.0= )
- jack? ( virtual/jack )
- !jack? ( media-libs/portaudio )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtprintsupport:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- )
- server? ( !app-admin/supernova )
- sndfile? ( media-libs/libsndfile )
- webengine? (
- dev-qt/qtwebchannel:5
- dev-qt/qtwebengine:5[widgets]
- dev-qt/qtwebsockets:5
- )
- X? (
- x11-libs/libX11
- x11-libs/libXt
- )
- zeroconf? ( net-dns/avahi )
-"
-DEPEND="${RDEPEND}
- dev-libs/icu
- emacs? ( >=app-editors/emacs-23.1:* )
- gedit? ( app-editors/gedit )
- qt5? ( dev-qt/qtconcurrent:5 )
- vim? ( app-editors/vim )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.10.2-no-ccache.patch
- "${FILESDIR}"/${P}-fewer-qt-deps.patch # Upstream PR 4991
- "${FILESDIR}"/${P}-fix-libscsynth-linker-issue.patch # Upstream issue 4992
- "${FILESDIR}"/${P}-boost-1.74.patch # bug 760489
-)
-
-S="${WORKDIR}/SuperCollider-${PV}-Source"
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_HELP=ON
- -DSYSTEM_BOOST=ON
- -DSYSTEM_YAMLCPP=ON
- -DSSE=$(usex cpu_flags_x86_sse)
- -DSSE2=$(usex cpu_flags_x86_sse2)
- -DSC_EL=$(usex emacs)
- -DFFT_GREEN=$(usex !fftw)
- -DSC_ED=$(usex gedit)
- -DNO_GPL3=$(usex !gpl3)
- -DAUDIOAPI=$(usex jack jack portaudio)
- -DSC_IDE=$(usex qt5)
- -DSC_QT=$(usex qt5)
- -DSCLANG_SERVER=$(usex server)
- -DSUPERNOVA=$(usex server)
- -DNO_LIBSNDFILE=$(usex !sndfile)
- -DLIBSCSYNTH=$(usex !static-libs)
- -DSC_VIM=$(usex vim)
- -DNO_X11=$(usex !X)
- -DNO_AVAHI=$(usex !zeroconf)
- )
-
- use qt5 && mycmakeargs+=(
- -DSC_USE_QTWEBENGINE=$(usex webengine)
- )
-
- use debug && mycmakeargs+=(
- -DSC_MEMORY_DEBUGGING=ON
- -DSN_MEMORY_DEBUGGING=ON
- -DGC_SANITYCHECK=ON
- )
-
- append-flags $(usex debug '' -DNDEBUG)
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- use emacs && newdoc editors/scel/README.md README.emacs
- use gedit && newdoc editors/sced/README.md README.gedit
- use vim && newdoc editors/scvim/README.md README.vim
-}
-
-src_test() {
- export QT_QPA_PLATFORM=offscreen
- cmake_src_test
-}
-
-pkg_postinst() {
- einfo "Notice: SuperCollider is not very intuitive to get up and running."
- einfo "The best course of action to make sure that the installation was"
- einfo "successful and get you started with using SuperCollider is to take"
- einfo "a look through ${EROOT}/usr/share/doc/${PF}/README.md.bz2"
-
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}