summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-06-18 16:38:43 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2023-06-18 16:41:14 +0200
commit0cebc25996b53ed0eec650b8a84a23eaf8dd1fc0 (patch)
tree4e4b7eb97d225d7d727ea77092a7c2bce6ab8940 /media-radio/qsstv/qsstv-9.5.8-r1.ebuild
parentapp-text/poppler: 23.06.0 version bump, subslot bump, add IUSE gpgme (diff)
downloadgentoo-0cebc25996b53ed0eec650b8a84a23eaf8dd1fc0.tar.gz
gentoo-0cebc25996b53ed0eec650b8a84a23eaf8dd1fc0.tar.bz2
gentoo-0cebc25996b53ed0eec650b8a84a23eaf8dd1fc0.zip
media-radio/qsstv: Move to media-libs/libpulse
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio/qsstv/qsstv-9.5.8-r1.ebuild')
-rw-r--r--media-radio/qsstv/qsstv-9.5.8-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-radio/qsstv/qsstv-9.5.8-r1.ebuild b/media-radio/qsstv/qsstv-9.5.8-r1.ebuild
new file mode 100644
index 000000000000..aeb2b1161913
--- /dev/null
+++ b/media-radio/qsstv/qsstv-9.5.8-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_P=${P/-/_}
+
+DESCRIPTION="Amateur radio SSTV software"
+HOMEPAGE="http://users.telenet.be/on4qz/"
+SRC_URI="http://users.telenet.be/on4qz/qsstv/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/hamlib:=
+ media-libs/openjpeg:2
+ media-libs/alsa-lib
+ media-libs/libv4l
+ sci-libs/fftw:3.0=
+ || (
+ media-libs/libpulse
+ media-sound/apulse[sdk]
+ )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ x11-misc/xdg-utils"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ eapply_user
+ # fix docdirectory, install path and hamlib search path
+ sed -i -e "s:/doc/\$\$TARGET:/doc/${PF}:" \
+ -e "s:-lhamlib:-L/usr/$(get_libdir)/hamlib -lhamlib:g" \
+ qsstv.pro || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README.txt
+}