summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-12-04 20:17:13 -0500
committerBrian Evans <grknight@gentoo.org>2022-12-04 20:17:56 -0500
commit080d7cae743cbe3a21195d3a9968420875c76772 (patch)
tree7a4321528da9af09d22112dc5eb8e552850d919e /mail-client/s-nail
parentmail-client/s-nail: Fix split-usr error (diff)
downloadgentoo-080d7cae743cbe3a21195d3a9968420875c76772.tar.gz
gentoo-080d7cae743cbe3a21195d3a9968420875c76772.tar.bz2
gentoo-080d7cae743cbe3a21195d3a9968420875c76772.zip
mail-client/s-nail: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'mail-client/s-nail')
-rw-r--r--mail-client/s-nail/Manifest1
-rw-r--r--mail-client/s-nail/s-nail-14.9.22.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/mail-client/s-nail/Manifest b/mail-client/s-nail/Manifest
index fc9b751b8fd0..013239401976 100644
--- a/mail-client/s-nail/Manifest
+++ b/mail-client/s-nail/Manifest
@@ -1,2 +1 @@
-DIST s-nail-14.9.22.tar.xz 799296 BLAKE2B 4db1b74be9de38d8879b00852545840aa50022f44efc42bc338575111e391db527ba850033a9f25e6d0269f68673a13bbdcd2609c0e74fb88c409040be2d165b SHA512 016e3403fbb3d9954c160690184545fdb4fc384ffb13b146ac8b60b40e43ad1b1a8967f4660904d40a99071eb1addf2b1dd98b06c6033a1a886379c05fc0c9be
DIST s-nail-14.9.24.tar.xz 803100 BLAKE2B 4d82c747ff082a1a13d8832eb2bf1e96f05d6b3cf61c77a67bc061b1971032b41d8f5fe5520b96b9b74bc4d0661a4a9ef0f8f93b5e7b9eef66906b78260cef2f SHA512 03f6a6f446391b6f91ed3c8875c3e7fdfac9d4e77ea1d52a7e98aa84cfd0edae137d5b9afba3bdc9a31ab67cee5237930b74b42ae3acb54aee4758553a4f1df2
diff --git a/mail-client/s-nail/s-nail-14.9.22.ebuild b/mail-client/s-nail/s-nail-14.9.22.ebuild
deleted file mode 100644
index 5dd4cf9fe267..000000000000
--- a/mail-client/s-nail/s-nail-14.9.22.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-HOMEPAGE="https://www.sdaoden.eu/code.html"
-DESCRIPTION="Enhanced mailx-compatible mail client based on Heirloom mailx (nail)"
-LICENSE="BSD BSD-4 ISC RSA"
-
-SRC_URI="https://ftp.sdaoden.eu/${P}.tar.xz"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="idn kerberos net ssl"
-
-RDEPEND="
- sys-libs/ncurses:0=
- virtual/libiconv
- idn? ( net-dns/libidn2 )
- net? (
- ssl? ( dev-libs/openssl:0= )
- kerberos? ( virtual/krb5 )
- )
- !mail-client/mailx
- !net-mail/mailutils
- !mail-client/nail
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils[extra-filters(-)]
- app-alternatives/awk
-"
-
-src_configure() {
- local confopts=(
- CC="$(tc-getCC)"
- EXTRA_CFLAGS=-std=c99
- strip=/bin/true
- OPT_AUTOCC=no
- VAL_PREFIX="${EPREFIX}"/usr
- VAL_SYSCONFDIR="${EPREFIX}"/etc
- VAL_MTA="${EPREFIX}/usr/sbin/sendmail"
- VAL_MAIL='/var/spool/mail'
- VAL_PAGER=less
- $(usex idn VAL_IDNA=idn2 OPT_IDNA=no)
- VERBOSE=1
- )
-
- if use net; then
- confopts+=( OPT_TLS=$(usex ssl require no)
- OPT_GSSAPI=$(usex kerberos require no)
- )
- else
- confopts+=( OPT_NET=no )
- fi
-
- tc-is-cross-compiler && confopts+=( OPT_CROSS_BUILD=yes )
-
- # Cannot use emake or bad options saved Bug 879065
- make "${confopts[@]}" config || die
-}
-
-src_compile() {
- emake build
-}
-
-src_install() {
- # Use /usr/sbin/sendmail by default and provide an example
- cat <<- EOSMTP >> nail.rc
-
- # Use the local sendmail (/usr/sbin/sendmail) binary by default.
- # (Uncomment the following line to use a SMTP server)
- #set smtp=localhost
-
- # Ask for CC: list too.
- set askcc
- EOSMTP
-
- emake DESTDIR="${D}" install
-
- dodoc INSTALL NEWS README THANKS
-
- dodir /bin
- dosym ../usr/bin/mailx /bin/mail
- dosym s-nail /usr/bin/mailx
- dosym mailx /usr/bin/mail
- dosym mailx /usr/bin/Mail
-
- dosym s-nail.1 /usr/share/man/man1/mailx.1
- dosym mailx.1 /usr/share/man/man1/mail.1
- dosym mailx.1 /usr/share/man/man1/Mail.1
-}