summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/ktp-text-ui
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/ktp-text-ui')
-rw-r--r--kde-apps/ktp-text-ui/Manifest1
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-18.08.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/Manifest b/kde-apps/ktp-text-ui/Manifest
index ad2abad2aee2..4f546eae2328 100644
--- a/kde-apps/ktp-text-ui/Manifest
+++ b/kde-apps/ktp-text-ui/Manifest
@@ -1 +1,2 @@
DIST ktp-text-ui-18.04.3.tar.xz 469688 BLAKE2B c1e43957d1ae541eb3371bbcef1da2d876e00f6db932861ca8154d448c134f05a9a4b2de1fc2efe791bddb7bdb0aab4dcf5409ba7f502fc07540bc4ec05d6d51 SHA512 b4b620d3a25307c027cca61fc3b814bb6f511feb10ae3baab176a9c0f86a4bb7101dc278b278dbaeb0d6556bd6fd7c42db3ac96c64178ee5c6db3ce47740c519
+DIST ktp-text-ui-18.08.1.tar.xz 470236 BLAKE2B 9305e281cefba730dc134c9473dccc92485b84cffb4d8f2e43a7abc60e5e58924f880e21254f2405d3f329299fc90b591ef195e465c26ed04bf7f828d9edf9e9 SHA512 50bf58e1a68b3bf6cc1ae280521dd54bebd2a47ad3f45005e4550bebea2b0d4ac46c25668051c513022bc8964383a89e69f85796392afca4c7eaa5b0b91957ba
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-18.08.1.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-18.08.1.ebuild
new file mode 100644
index 000000000000..d8d737632890
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-18.08.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5(+)]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}