summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-12 20:36:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-12 20:36:02 +0200
commit4186eabcad11c1cf1a6fdc6a555b72404eee0137 (patch)
tree7a07ac977ec9f17772623b3ec02801d5dad964f9 /kde-apps/ark
parentapp-crypt/certbot: fixing acme dep (diff)
downloadgentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.tar.gz
gentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.tar.bz2
gentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.zip
kde-apps: Add KDE Applications 18.04.3
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-18.04.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index b9268d419c27..410861dc1bb7 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.12.3.tar.xz 1970120 BLAKE2B b8e14f6b5f541c514107cf76b612edd99d6e0d97dfbe7600349bdcf2bd5afbfd1fcaf256d0358ff0c8838d8334a14ddd1ac5d29ce9befebe960444e0828aba5e SHA512 2f32f0107afa20ef115caddaf3c7ce6be37a575c72ea440f571312309d945a0e0491a4327db379e8ca7622a2b5016c5b2bbbfb3377d3b4272430f85b23fbb911
DIST ark-18.04.2.tar.xz 1973540 BLAKE2B 64bb00807ec0fa0511448bfb6d4e35bae3034b00058806b82a93c753f6dcfa61b75cd5601c42bfccbec3507003864f4543bc87c98cb66a303bc6f192d3d7a96f SHA512 bf3b26ec61a39585505a6e0818dc075424886625c7bb4aed4cb3359fbcb3463e8eaeb186434532eed4612db7968d1d59349013e179c3ef25f241f5070c244358
+DIST ark-18.04.3.tar.xz 1973656 BLAKE2B afa413156233a31a1c7d102799b347b6879453a4c0a870511cb9040c9160c4da4eab30722ad9ec07ec1e9b68e942c137c464e0054738d8ee3632546b49c9dc93 SHA512 39348d3cbd3ed044ecc40a235c3e93dacb638e3ea867f814c722630786fbf7ea48643f967fb46f3358c64966a250306f11ab2a76c9147bc135ba826bcce9d33d
diff --git a/kde-apps/ark/ark-18.04.3.ebuild b/kde-apps/ark/ark-18.04.3.ebuild
new file mode 100644
index 000000000000..7a5bb558b1c2
--- /dev/null
+++ b/kde-apps/ark/ark-18.04.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "For extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+
+ has_version app-arch/rar || \
+ elog "For creating rar archives, installing app-arch/rar is required."
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+}