summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-17 16:36:35 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-17 16:52:17 +0200
commit690e0cd6985e6c71e7115c645db5089799232b02 (patch)
treefeaa963efcde6b1682754483d47936dfc83518a2 /gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen
parentdev-python/rapidfuzz: Bump to 3.0.0 (diff)
downloadgentoo-690e0cd6985e6c71e7115c645db5089799232b02.tar.gz
gentoo-690e0cd6985e6c71e7115c645db5089799232b02.tar.bz2
gentoo-690e0cd6985e6c71e7115c645db5089799232b02.zip
gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen: add 20230408
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20230408.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
index 22bdb49dfeca..2d6416f8066c 100644
--- a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20220323.tar.gz 2618 BLAKE2B 050f801bcc1ced63647c49badb779ce60a7de329ecebfef324cb8d1992e992933524a5e0e08272cf93bd9e24c9be72ba3b1365721b7954422ae0dfab7c1448bf SHA512 c13bff5676d5cf5ad6c932c6f19f1229fe65b3c4c0bcad6d0f3dfbce5bb763ebbd5cea7140e7b3ad5417819ee27e4e49369740d634b13b7f037fa4dc324dbced
+DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20230408.tar.gz 18303 BLAKE2B e15c4cb3274e0c295162dbb4788f9668d16b17f38bff0f8c45716202470c29986d28df19efdeda707365dc3b229a1dccb4c7b9fe4cfab7868d6286ac7ccf561b SHA512 4167587a1786f06a559975a393c2dac7fd54f4abeab902adbbd9637ef7a2399ad1e8e5a52f881559766599c8905ce501a3febb020f0b300b0a1ce5450d04052d
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20230408.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20230408.ebuild
new file mode 100644
index 000000000000..2125b3aea854
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20230408.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="53b17ccf60dedd815be4657d6e3655d838a984df"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-44
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+S="${WORKDIR}/${PN/gnome-shell-extension-/}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf LICENSE README.md schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}