summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-10-01 17:01:01 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-10-04 12:52:40 -0400
commit63c80c5955c292656d90663c9b0a949569884d1b (patch)
tree83e078a82fbbde62318b6bd875cb4f8bfef758b4 /games-puzzle
parentnet-wireless/qdmr: stabilize 0.8.1 (diff)
downloadgentoo-63c80c5955c292656d90663c9b0a949569884d1b.tar.gz
gentoo-63c80c5955c292656d90663c9b0a949569884d1b.tar.bz2
gentoo-63c80c5955c292656d90663c9b0a949569884d1b.zip
games-puzzle/gemdropx: EAPI8 bump, ebuild improvements
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gemdropx/gemdropx-0.9-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-puzzle/gemdropx/gemdropx-0.9-r3.ebuild b/games-puzzle/gemdropx/gemdropx-0.9-r3.ebuild
new file mode 100644
index 000000000000..81cfe01a5604
--- /dev/null
+++ b/games-puzzle/gemdropx/gemdropx-0.9-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Puzzle game where it's your job to clear the screen of gems"
+HOMEPAGE="http://www.newbreedsoftware.com/gemdropx/"
+SRC_URI="ftp://ftp.tuxpaint.org/unix/x/gemdropx/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/$(CFLAGS) -o/$(LDFLAGS) -o/' \
+ Makefile || die
+ rm -r data/images/.xvpics || die
+}
+
+src_compile() {
+ local myemakeargs=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCC)"
+ DATA_PREFIX="${EPREFIX}/usr/share/${PN}"
+ XTRA_FLAGS="${CFLAGS}"
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r data/.
+
+ dodoc AUTHORS.txt CHANGES.txt ICON.txt README.txt TODO.txt
+
+ newicon data/images/${PN}-icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Gem Drop X"
+}