summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-20 03:00:43 +0000
committerSam James <sam@gentoo.org>2022-01-20 03:00:43 +0000
commit1956405d5a510da460f0ab36d3937226953e2d12 (patch)
tree60df55cfe59e527517cfed01c496f1f5dc6da3e5 /games-puzzle/hitori
parentmedia-libs/mesa: Stabilize 21.3.4 x86, #831378 (diff)
downloadgentoo-1956405d5a510da460f0ab36d3937226953e2d12.tar.gz
gentoo-1956405d5a510da460f0ab36d3937226953e2d12.tar.bz2
gentoo-1956405d5a510da460f0ab36d3937226953e2d12.zip
games-puzzle/hitori: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831462 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle/hitori')
-rw-r--r--games-puzzle/hitori/files/hitori-3.38.3-meson-0.61-build.patch35
-rw-r--r--games-puzzle/hitori/hitori-3.38.3.ebuild6
2 files changed, 40 insertions, 1 deletions
diff --git a/games-puzzle/hitori/files/hitori-3.38.3-meson-0.61-build.patch b/games-puzzle/hitori/files/hitori-3.38.3-meson-0.61-build.patch
new file mode 100644
index 000000000000..a89b1b498502
--- /dev/null
+++ b/games-puzzle/hitori/files/hitori-3.38.3-meson-0.61-build.patch
@@ -0,0 +1,35 @@
+https://gitlab.gnome.org/GNOME/hitori/-/commit/d25728e122f1d7b985029a5ba96810c3e57c27f7.patch
+https://bugs.gentoo.org/831462
+
+From: Philip Withnall <pwithnall@endlessos.org>
+Date: Tue, 2 Nov 2021 12:04:29 +0000
+Subject: [PATCH] build: Drop positional arguments from i18n.merge_file() calls
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Meson never took positional arguments in this function, but didn’t warn
+about it until Meson 0.60. Drop the unnecessary arguments to fix the
+warning.
+
+Signed-off-by: Philip Withnall <pwithnall@endlessos.org>
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -1,6 +1,6 @@
+ subdir('icons')
+
+-desktop_file = i18n.merge_file('desktop-file',
++desktop_file = i18n.merge_file(
+ type: 'desktop',
+ input: '@0@.desktop.in'.format(application_id),
+ output: '@0@.desktop'.format(application_id),
+@@ -20,7 +20,7 @@ if desktop_file_validate.found()
+ )
+ endif
+
+-appdata_file = i18n.merge_file('appdata-file',
++appdata_file = i18n.merge_file(
+ input: '@0@.appdata.xml.in'.format(application_id),
+ output: '@0@.appdata.xml'.format(application_id),
+ po_dir: join_paths(meson.source_root(), 'po'),
+GitLab
diff --git a/games-puzzle/hitori/hitori-3.38.3.ebuild b/games-puzzle/hitori/hitori-3.38.3.ebuild
index 03d77e2e63fd..e6f87c980f0f 100644
--- a/games-puzzle/hitori/hitori-3.38.3.ebuild
+++ b/games-puzzle/hitori/hitori-3.38.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-0.61-build.patch
+)
+
pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update