summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-27 15:55:59 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-27 15:56:48 -0600
commite5c2e9d32acc5be6f1c41f1fd916c6ba7ed4f029 (patch)
treeea59db6c6d31d1caa6c0473035cc44d03cf29f19 /games-action/shootingstar
parentmedia-libs/lcms: Add patch for out-of-bounds read in Type_MLU_Read() (CVE-201... (diff)
downloadgentoo-e5c2e9d32acc5be6f1c41f1fd916c6ba7ed4f029.tar.gz
gentoo-e5c2e9d32acc5be6f1c41f1fd916c6ba7ed4f029.tar.bz2
gentoo-e5c2e9d32acc5be6f1c41f1fd916c6ba7ed4f029.zip
games-action/shootingstar: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/shootingstar')
-rw-r--r--games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch4
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0-r1.ebuild54
2 files changed, 56 insertions, 2 deletions
diff --git a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
index 179cf09ebda3..dfc1a8d8e77e 100644
--- a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
+++ b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
@@ -1,5 +1,5 @@
---- src/engine/dbg.cpp.old 2009-06-03 15:15:46.000000000 +0200
-+++ src/engine/dbg.cpp 2009-06-03 16:09:19.000000000 +0200
+--- a/src/engine/dbg.cpp 2009-06-03 15:15:46.000000000 +0200
++++ b/src/engine/dbg.cpp 2009-06-03 16:09:19.000000000 +0200
@@ -28,6 +28,7 @@
#include <vector>
#include <map>
diff --git a/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..5b6920a44d10
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+# Note: currently segfaults on startup, but that's also in the previous ebuild
+# See https://bugs.gentoo.org/607428
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gcc34.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install () {
+ default
+ newicon -s 128 data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}