summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /dev-vcs
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/breezy/breezy-3.3.5-r1.ebuild (renamed from dev-vcs/breezy/breezy-3.3.5.ebuild)0
-rw-r--r--dev-vcs/breezy/breezy-3.3.7-r2.ebuild (renamed from dev-vcs/breezy/breezy-3.3.7-r1.ebuild)0
-rw-r--r--dev-vcs/git-absorb/git-absorb-0.6.15-r1.ebuild (renamed from dev-vcs/git-absorb/git-absorb-0.6.15.ebuild)0
-rw-r--r--dev-vcs/mercurial/mercurial-6.5.3-r2.ebuild (renamed from dev-vcs/mercurial/mercurial-6.5.3-r1.ebuild)5
-rw-r--r--dev-vcs/mercurial/mercurial-6.6.2-r2.ebuild (renamed from dev-vcs/mercurial/mercurial-6.6.2-r1.ebuild)3
-rw-r--r--dev-vcs/mercurial/mercurial-6.7.4-r2.ebuild (renamed from dev-vcs/mercurial/mercurial-6.7.4-r1.ebuild)3
-rw-r--r--dev-vcs/mercurial/mercurial-6.8.1-r1.ebuild (renamed from dev-vcs/mercurial/mercurial-6.8.1.ebuild)3
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild3
-rw-r--r--dev-vcs/stgit/stgit-2.4.11-r1.ebuild (renamed from dev-vcs/stgit/stgit-2.4.11.ebuild)0
-rw-r--r--dev-vcs/stgit/stgit-2.4.12-r1.ebuild (renamed from dev-vcs/stgit/stgit-2.4.12.ebuild)0
-rw-r--r--dev-vcs/stgit/stgit-2.4.6-r1.ebuild (renamed from dev-vcs/stgit/stgit-2.4.6.ebuild)0
11 files changed, 16 insertions, 1 deletions
diff --git a/dev-vcs/breezy/breezy-3.3.5.ebuild b/dev-vcs/breezy/breezy-3.3.5-r1.ebuild
index 215f1f5ffa2c..215f1f5ffa2c 100644
--- a/dev-vcs/breezy/breezy-3.3.5.ebuild
+++ b/dev-vcs/breezy/breezy-3.3.5-r1.ebuild
diff --git a/dev-vcs/breezy/breezy-3.3.7-r1.ebuild b/dev-vcs/breezy/breezy-3.3.7-r2.ebuild
index 695dc3e7e9a0..695dc3e7e9a0 100644
--- a/dev-vcs/breezy/breezy-3.3.7-r1.ebuild
+++ b/dev-vcs/breezy/breezy-3.3.7-r2.ebuild
diff --git a/dev-vcs/git-absorb/git-absorb-0.6.15.ebuild b/dev-vcs/git-absorb/git-absorb-0.6.15-r1.ebuild
index c3b68e62d3d7..c3b68e62d3d7 100644
--- a/dev-vcs/git-absorb/git-absorb-0.6.15.ebuild
+++ b/dev-vcs/git-absorb/git-absorb-0.6.15-r1.ebuild
diff --git a/dev-vcs/mercurial/mercurial-6.5.3-r1.ebuild b/dev-vcs/mercurial/mercurial-6.5.3-r2.ebuild
index ef5aaf4ea840..969e0594fd27 100644
--- a/dev-vcs/mercurial/mercurial-6.5.3-r1.ebuild
+++ b/dev-vcs/mercurial/mercurial-6.5.3-r2.ebuild
@@ -161,12 +161,15 @@ CRATES="
zstd-sys-2.0.7+zstd.1.5.4
"
+# for stdsimd
+RUST_MAX_VER=1.77.1
+
inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz
- rust? ( $(cargo_crate_uris ${CRATES}) )"
+ rust? ( ${CARGO_CRATE_URIS} )"
LICENSE="GPL-2+
rust? ( 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD MIT MPL-2.0 PSF-2 Unicode-DFS-2016 Unlicense ZLIB )"
diff --git a/dev-vcs/mercurial/mercurial-6.6.2-r1.ebuild b/dev-vcs/mercurial/mercurial-6.6.2-r2.ebuild
index 08e2955bc986..9ee1dc0cfb34 100644
--- a/dev-vcs/mercurial/mercurial-6.6.2-r1.ebuild
+++ b/dev-vcs/mercurial/mercurial-6.6.2-r2.ebuild
@@ -170,6 +170,9 @@ CRATES="
zstd-sys@2.0.7+zstd.1.5.4
"
+# for stdsimd
+RUST_MAX_VER=1.77.1
+
inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
DESCRIPTION="Scalable distributed SCM"
diff --git a/dev-vcs/mercurial/mercurial-6.7.4-r1.ebuild b/dev-vcs/mercurial/mercurial-6.7.4-r2.ebuild
index 564e460089e9..f68c7388f014 100644
--- a/dev-vcs/mercurial/mercurial-6.7.4-r1.ebuild
+++ b/dev-vcs/mercurial/mercurial-6.7.4-r2.ebuild
@@ -181,6 +181,9 @@ CRATES="
zstd-sys@2.0.7+zstd.1.5.4
"
+# for stdsimd
+RUST_MAX_VER=1.77.1
+
inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
DESCRIPTION="Scalable distributed SCM"
diff --git a/dev-vcs/mercurial/mercurial-6.8.1.ebuild b/dev-vcs/mercurial/mercurial-6.8.1-r1.ebuild
index f0b887149ad7..2e09a308c5df 100644
--- a/dev-vcs/mercurial/mercurial-6.8.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-6.8.1-r1.ebuild
@@ -201,6 +201,9 @@ CRATES="
zstd-sys@2.0.7+zstd.1.5.4
"
+# for stdsimd
+RUST_MAX_VER=1.77.1
+
inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
DESCRIPTION="Scalable distributed SCM"
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 45093fbe0880..3d26e755559c 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -9,6 +9,9 @@ DISTUTILS_EXT=1
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
+# for stdsimd
+RUST_MAX_VER=1.77.1
+
inherit bash-completion-r1 cargo elisp-common distutils-r1 mercurial flag-o-matic multiprocessing
DESCRIPTION="Scalable distributed SCM"
diff --git a/dev-vcs/stgit/stgit-2.4.11.ebuild b/dev-vcs/stgit/stgit-2.4.11-r1.ebuild
index 4ad2d8e33b6a..4ad2d8e33b6a 100644
--- a/dev-vcs/stgit/stgit-2.4.11.ebuild
+++ b/dev-vcs/stgit/stgit-2.4.11-r1.ebuild
diff --git a/dev-vcs/stgit/stgit-2.4.12.ebuild b/dev-vcs/stgit/stgit-2.4.12-r1.ebuild
index 84fa72cec8d1..84fa72cec8d1 100644
--- a/dev-vcs/stgit/stgit-2.4.12.ebuild
+++ b/dev-vcs/stgit/stgit-2.4.12-r1.ebuild
diff --git a/dev-vcs/stgit/stgit-2.4.6.ebuild b/dev-vcs/stgit/stgit-2.4.6-r1.ebuild
index e815ddb4c129..e815ddb4c129 100644
--- a/dev-vcs/stgit/stgit-2.4.6.ebuild
+++ b/dev-vcs/stgit/stgit-2.4.6-r1.ebuild