summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-04-15 23:03:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-04-16 22:16:33 -0400
commit1f92c65eca140afc71a52e6b4036cb41b76710a0 (patch)
treec554e4338a0e1412aba988e2552170b5a4d37acf /dev-util/mingw64-runtime
parentdev-util/mingw64-runtime: add myself as a maintainer (diff)
downloadgentoo-1f92c65eca140afc71a52e6b4036cb41b76710a0.tar.gz
gentoo-1f92c65eca140afc71a52e6b4036cb41b76710a0.tar.bz2
gentoo-1f92c65eca140afc71a52e6b4036cb41b76710a0.zip
dev-util/mingw64-runtime: add 10.0.0
This version fixes building with vanilla binutils-2.38 wrt bug #838157, and the (now keyworded) >=binutils-2.38-r2 backport also fixed it for all versions. Includes some ebuild cleanups/changes: - EAPI7->8 - drop unused autotools inherit - update HOMEPAGE to https non-sourceforge link - update LICENSE, main license is ZPL + others, and tools are GPL-3+ (could probably still use revision) - remove obsolete rdtsc patch (was bug #786549), been fixed since 9.0.0 but the fix is different and was letting our patch apply - namespace is_crosscompile() to avoid confusing pkgcheck, note that this is toolchain.eclass' version which is different than tc-is-cross-compiler - inline just_headers/alt_prefix/crt_with(), left crt's use_with and use_enable alone given it's less jarring and may have additional uses in the future - move src_configure-only functions inside src_configure - use econf with ECONF_SOURCE over direct ${S}/configure - add missing || die for rm / mkdir / push+popd / cpp+grep (for cpp, use a case statement for clarity and no tmp variables) - drop rm's -f, haven't found a situation where it'd fail - misc style changes like using arrays for econf Not touching CHOST/CATEGORY/symlinks and friends given haven't fully reviewed implications for this package + crossdev. Closes: https://bugs.gentoo.org/838157 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/Manifest1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-10.0.0.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-util/mingw64-runtime/Manifest b/dev-util/mingw64-runtime/Manifest
index 28cfb0b7ae47..46f60d52481b 100644
--- a/dev-util/mingw64-runtime/Manifest
+++ b/dev-util/mingw64-runtime/Manifest
@@ -1,3 +1,4 @@
+DIST mingw-w64-v10.0.0.tar.bz2 9620291 BLAKE2B 451372403289c492ca939d65bb4d9f6e9fa6bdd6b32d79d6438d858e106e8cc291712ada1f3f7b951a4c6908e7d0385d485ca76920af39bcf86effa48408e330 SHA512 3c0827af7c40809a867758f6cd9ef3ff0c988b43082345bf725e03949af95968d634ace99a7ffae323189549221dcb5d861de9e801f1fbc7904e446641b60516
DIST mingw-w64-v7.0.0.tar.bz2 9071231 BLAKE2B da00794ec456ede5913a565248c79255407c058469cb7338cf81b8d03c1e39f4189016b01734b786c0ad8f18166a24fdb95ca72edc954f31151e5d3aa2b2a899 SHA512 30e5b2824a24eeb99ab519e3fc134cc9a7f04ee8b853bc8d66a13d1ab74144bf78b93e162bfe6de2a5e61f63c0e620a933b260b02d019cd68cc4b78bd36c67fd
DIST mingw-w64-v8.0.0.tar.bz2 9370799 BLAKE2B ec65191722f6f2ddbb93488ea4c4c21e22fb5ef777ef293d65d13de1057d96c9105a4a4936999d4babbd8fdfc52ed14675f1c5fbc630524df28805e0f66b1a2b SHA512 cefcc86ac3e6337c88ed224ab4692abbd5eb543ce78fb6c5462198a85f36c9274a0a1df0a0bebd182137fd527c15831f9237c782711a85f32e77d9104b28359e
DIST mingw-w64-v9.0.0.tar.bz2 9537758 BLAKE2B 298b97f50c7632972aee2c75e90de0776f64c1dd5aaeb52d4e4be10a8e0365efee82c93179990cc090cc7b9f83525a7abf51a5d069b7a3e39abb37fdb733a70c SHA512 6691331a2ab521d22c1d32bebe0ed049bd62a7a7722cff38e7792b4e42c6b8df4356084afff6c916b487b3ebddc4372b398ab7cd0c7f4ff6991a70fe64177386
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0.ebuild
new file mode 100644
index 000000000000..cf08ceab0f13
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} && ${CATEGORY} == cross-* ]]; then
+ export CTARGET=${CATEGORY#cross-}
+fi
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="https://www.mingw-w64.org/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+LICENSE="ZPL BSD BSD-2 ISC LGPL-2+ LGPL-2.1+ MIT public-domain tools? ( GPL-3+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# USE=libraries needs working stage2 compiler: bug #665512
+IUSE="headers-only idl libraries tools"
+RESTRICT="strip"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.0-fortify-only-ssp.patch
+)
+
+mingw-is_cross() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} && ${CHOST} == ${CTARGET} ]]; then
+ die "Invalid configuration"
+ fi
+}
+
+src_configure() {
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ # Normally mingw-64 does not use dynamic linker.
+ # But at configure time it uses $LDFLAGS.
+ # When default -Wl,--hash-style=gnu is passed
+ # __CTORS_LIST__ / __DTORS_LIST__ is mis-detected
+ # for target ld and binaries crash at shutdown.
+ filter-ldflags '-Wl,--hash-style=*'
+
+ if use !headers-only; then
+ mkdir "${WORKDIR}"/headers || die
+ pushd "${WORKDIR}"/headers >/dev/null || die
+
+ local econfargs=(
+ --prefix="${T}"/tmproot
+ --with-headers
+ --without-crt
+ )
+
+ CHOST=${CTARGET} ECONF_SOURCE=${S} econf "${econfargs[@]}"
+
+ popd >/dev/null || die
+
+ append-cppflags "-I${T}/tmproot/include"
+ fi
+
+ crt-use_enable() {
+ use headers-only && echo --without-${2:-${1}} || use_enable "${@}"
+ }
+ crt-use_with() {
+ use headers-only && echo --without-${2:-${1}} || use_with "${@}"
+ }
+
+ local prefix="${EPREFIX}"$(mingw-is_cross && echo /usr/${CTARGET})/usr
+ local econfargs=(
+ --prefix="${prefix}"
+ --libdir="${prefix}"/lib
+ --enable-sdk
+ --with-headers
+
+ # By default configure tries to set --sysroot=${prefix}. We disable
+ # this behaviour with --with-sysroot=no to use gcc's sysroot default.
+ # That way we can cross-build mingw64-runtime with cross-emerge.
+ --with-sysroot=no
+
+ $(use_with !headers-only crt)
+ $(crt-use_enable idl)
+ $(crt-use_with libraries)
+ $(crt-use_with tools)
+ $(
+ $(tc-getCPP ${CTARGET}) ${CPPFLAGS} -dM - </dev/null | grep -q __MINGW64__
+ case ${PIPESTATUS[*]} in
+ '0 0') echo --disable-lib32 --enable-lib64;;
+ '0 1') echo --enable-lib32 --disable-lib64;;
+ *) die "failed check for __MINGW64__";;
+ esac
+ )
+ )
+
+ CHOST=${CTARGET} econf "${econfargs[@]}"
+}
+
+src_compile() {
+ use headers-only || emake -C "${WORKDIR}"/headers install
+
+ default
+}
+
+src_install() {
+ default
+
+ if mingw-is_cross; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ rm -r "${ED}"/usr/share || die
+}