summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-15 17:07:44 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-15 17:09:21 +0200
commitc845f794adf558e1b96917304afa805257d6ee36 (patch)
tree754d31463213bbf9cbf9f612f45f90a1d61cbccd /dev-util/devhelp
parentapp-dicts/gnome-dictionary: version bump 3.20.0 → 3.24.0 (diff)
downloadgentoo-c845f794adf558e1b96917304afa805257d6ee36.tar.gz
gentoo-c845f794adf558e1b96917304afa805257d6ee36.tar.bz2
gentoo-c845f794adf558e1b96917304afa805257d6ee36.zip
dev-util/devhelp: version bump 3.22.0 → 3.24.0
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/Manifest1
-rw-r--r--dev-util/devhelp/devhelp-3.24.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/devhelp/Manifest b/dev-util/devhelp/Manifest
index c4d636d191c8..f6954c004658 100644
--- a/dev-util/devhelp/Manifest
+++ b/dev-util/devhelp/Manifest
@@ -1 +1,2 @@
DIST devhelp-3.22.0.tar.xz 491908 SHA256 59cae02e12d238cc5fc3f049d779895ba89701426d9173f5b534d4ab90c5ffb0 SHA512 16d9853c4514d7b28381e3755e34682a2e9d64d666bb7d39094289d4990eb981efac041b7bf7f8beef5a018cab71c461ecd4e7b7a099fbc132f5b8f7b79749dc WHIRLPOOL a46088f7cf373106cfecaa87f2cac350e05fb94dc925f12e22f9f000754124dfe62845d23a14689c386167e54f0b74bdd4ec5bb2b08b0aad61c54d5f16070713
+DIST devhelp-3.24.0.tar.xz 615460 SHA256 4858de1c815532ad160d1bf9facd28859972e3a052908a8edf73f866c8cce430 SHA512 56b1eeaf9d3c3357d3140002bed5c29bf7b21953d964405190a1c9cad69d08000efa0220bbc36c67db4151b15ee37c37e061e6fa63c8a79f626e1ec0ce386062 WHIRLPOOL fb0502408fd14ce12b77ae6f0a08cde6d95ea48ac8737ced17e845f4f4fd22eb9233acf656c1ccebec30f200905848fc87da6e0aad8bb0bf4b750df1123cc56c
diff --git a/dev-util/devhelp/devhelp-3.24.0.ebuild b/dev-util/devhelp/devhelp-3.24.0.ebuild
new file mode 100644
index 000000000000..a22c80a3b51b
--- /dev/null
+++ b/dev-util/devhelp/devhelp-3.24.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# gedit-3.8 is python3 only, this also per:
+# https://bugzilla.redhat.com/show_bug.cgi?id=979450
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit gnome2 python-single-r1 toolchain-funcs
+
+DESCRIPTION="An API documentation browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
+
+LICENSE="GPL-2+"
+SLOT="0/3-3" # subslot = 3-(libdevhelp-3 soname version)
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="gedit +introspection"
+REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.38:2[dbus]
+ >=x11-libs/gtk+-3.20:3
+ >=net-libs/webkit-gtk-2.6.0:4
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gedit? (
+ ${PYTHON_DEPS}
+ app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+[introspection] )
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# dev-libs/appstream-glib
+# sys-devel/autoconf-archive
+
+pkg_setup() {
+ use gedit && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if ! use gedit ; then
+ sed -e '/SUBDIRS/ s/gedit-plugin//' -i misc/Makefile.{am,in} || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ # ICC is crazy, silence warnings (bug #154010)
+ if [[ $(tc-getCC) == "icc" ]] ; then
+ myconf="--with-compile-warnings=no"
+ fi
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ ${myconf}
+}