summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-01-27 11:12:07 -0600
committerBen Kohler <bkohler@gentoo.org>2024-01-27 11:13:09 -0600
commited2ea05fdfde812665d40d35b44f48b4de60deb0 (patch)
treee2eb529f6b3e9455fd90fd3c7ccc0fb799e3a6f5 /dev-util/catalyst
parentdev-lisp/ecl: Stabilize 23.9.9-r1 amd64, #922646 (diff)
downloadgentoo-ed2ea05fdfde812665d40d35b44f48b4de60deb0.tar.gz
gentoo-ed2ea05fdfde812665d40d35b44f48b4de60deb0.tar.bz2
gentoo-ed2ea05fdfde812665d40d35b44f48b4de60deb0.zip
dev-util/catalyst: remove extra (wrong) man page installations
Closes: https://bugs.gentoo.org/923039 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/catalyst-4.0_rc1.ebuild5
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild7
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-util/catalyst/catalyst-4.0_rc1.ebuild b/dev-util/catalyst/catalyst-4.0_rc1.ebuild
index 3a8ec2cf9cb1..9bf921904e91 100644
--- a/dev-util/catalyst/catalyst-4.0_rc1.ebuild
+++ b/dev-util/catalyst/catalyst-4.0_rc1.ebuild
@@ -106,6 +106,11 @@ python_install_all() {
fi
}
+python_install() {
+ distutils-r1_python_install
+ rm -rv "${D}"$(python_get_sitedir)/usr
+}
+
src_install() {
distutils-r1_src_install
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index ab85324f0c98..c5bd9ff2d041 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -103,6 +103,11 @@ python_install_all() {
fi
}
+python_install() {
+ distutils-r1_python_install
+ rm -rv "${D}"$(python_get_sitedir)/usr
+}
+
src_install() {
distutils-r1_src_install