summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-12 06:20:54 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-12 06:20:54 +0200
commit6ccb6ed754431345f845f1435d328252e297f2dc (patch)
tree14aa221f27c048da5bc73376fbfb06b1678c452d /dev-ruby
parentpackage.mask: Mask dev-python/scikit-build-core again (diff)
downloadgentoo-6ccb6ed754431345f845f1435d328252e297f2dc.tar.gz
gentoo-6ccb6ed754431345f845f1435d328252e297f2dc.tar.bz2
gentoo-6ccb6ed754431345f845f1435d328252e297f2dc.zip
dev-ruby/public_suffix: add 5.0.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/public_suffix/Manifest1
-rw-r--r--dev-ruby/public_suffix/public_suffix-5.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/public_suffix/Manifest b/dev-ruby/public_suffix/Manifest
index f6eccccee33a..fef8a8ebc96a 100644
--- a/dev-ruby/public_suffix/Manifest
+++ b/dev-ruby/public_suffix/Manifest
@@ -1,2 +1,3 @@
DIST public_suffix-4.0.7.gem 113664 BLAKE2B 5da86713da01f59e7f311985a36b835e02807ca5f186ffc5e41e42cae7781cc10d96a4aca77dafb77050c78e6fb03e10f7ac55dace776c5cca68bca9f4bd7d75 SHA512 acdfe135684277a669ceaa61ea78fc70b979614f63daf27d145e78e4013221eac106651838a27b6694844f4fc33521ecc9f81102582ca1f1232fa80ce8191207
DIST public_suffix-5.0.1.gem 114688 BLAKE2B 7d1f2bf8b05c4de548b281f01a50eba8911ca9d56f42301139e0e3242eb9960db7b6fe312f4b65996b9b796fcc84748c53968771417b45773a453dc99b2fa33b SHA512 9498d53af79ffa7ccf5f94eb4e54c2281ff3e025d963c9024aeac06efa919dcf766a51f901ab6168125737b6f53831f8835d5777739fc45ddb66c99c2e573746
+DIST public_suffix-5.0.3.gem 113152 BLAKE2B e14a5c343f4db466a31c3a84c95f810d82b5bf64d6be9e0690d9639aaae8feec91ffb1e867dcb3664027426c436396a090a7051189308414b76c4f962c899930 SHA512 7d8c1c0ff951458060dfee4247cfdb04a3f875f97e8451e2955b05335c9ea8480612be1455280ee86c9b2a1c62d0dac663d67b68825d8ce3a99ef63c5841017d
diff --git a/dev-ruby/public_suffix/public_suffix-5.0.3.ebuild b/dev-ruby/public_suffix/public_suffix-5.0.3.ebuild
new file mode 100644
index 000000000000..9fa9780bd520
--- /dev/null
+++ b/dev-ruby/public_suffix/public_suffix-5.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse and decompose a domain name into top level domain, domain and subdomains"
+HOMEPAGE="https://simonecarletti.com/code/publicsuffix-ruby/"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha:1.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' \
+ -e '/yard/,/CLOBBER.include/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
+}