summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/classifier-reborn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/classifier-reborn')
-rw-r--r--dev-ruby/classifier-reborn/Manifest1
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.0.3.ebuild33
-rw-r--r--dev-ruby/classifier-reborn/metadata.xml8
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/classifier-reborn/Manifest b/dev-ruby/classifier-reborn/Manifest
new file mode 100644
index 000000000000..9e13d5d0eeb6
--- /dev/null
+++ b/dev-ruby/classifier-reborn/Manifest
@@ -0,0 +1 @@
+DIST classifier-reborn-2.0.3.tar.gz 22888 SHA256 3cee84bd7bee0b6d64d94d370736eda7283a933afcc8e5b0a93af88e83937213 SHA512 37e6c078de65ac7851acc9e5ea3ffbad2dfde1923bf765b6cd936457cdf52d3738e35b84d1ef94e1b5af396e1821f09749090d29fdfaf121f0a0ac50ec9b1418 WHIRLPOOL d5ae8072aaf977404bc389473ce9ce8071c70cc10f886232fd292afa39a879030e6e1ee310fa60d61e36048074da9a8729eeba179cd92798bef1924604071d74
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.0.3.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.0.3.ebuild
new file mode 100644
index 000000000000..d4e0c0c79ba3
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl test"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/'\
+ -e 's/vector_serialize/vector/'\
+ -i lib/${PN}/lsi.rb || die
+ fi
+}
diff --git a/dev-ruby/classifier-reborn/metadata.xml b/dev-ruby/classifier-reborn/metadata.xml
new file mode 100644
index 000000000000..2a647b31e380
--- /dev/null
+++ b/dev-ruby/classifier-reborn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jekyll/classifier-reborn</remote-id>
+ </upstream>
+</pkgmetadata>