summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-28 08:04:25 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-28 08:24:17 +0100
commit872b6f77fd9fec6a3c6d574e675befc00e7159b8 (patch)
treeb6abf23b0345ceb85a564fce0e99fd223e8293c5 /dev-ruby/bunny/bunny-2.13.0.ebuild
parentdev-ruby/bundler: add 1.17.3 (diff)
downloadgentoo-872b6f77fd9fec6a3c6d574e675befc00e7159b8.tar.gz
gentoo-872b6f77fd9fec6a3c6d574e675befc00e7159b8.tar.bz2
gentoo-872b6f77fd9fec6a3c6d574e675befc00e7159b8.zip
dev-ruby/bunny: add 2.13.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/bunny/bunny-2.13.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.13.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.13.0.ebuild b/dev-ruby/bunny/bunny-2.13.0.ebuild
new file mode 100644
index 000000000000..442737d09b5d
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.13.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.0:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}