summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-26 07:35:40 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-26 08:32:31 +0200
commit2326000c403d28110aca42fef21b34971d137e8e (patch)
treeaf9cd9f2fe842aaca54a55c44a53b1bbc63ffe1a /dev-ruby/asciidoctor
parentdev-ruby/hiera-eyaml-gpg: enable ruby32 (diff)
downloadgentoo-2326000c403d28110aca42fef21b34971d137e8e.tar.gz
gentoo-2326000c403d28110aca42fef21b34971d137e8e.tar.bz2
gentoo-2326000c403d28110aca42fef21b34971d137e8e.zip
dev-ruby/asciidoctor: add 2.0.23
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/asciidoctor')
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.23.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index 1fd855716cb5..dca65cdeaa6a 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1,3 +1,4 @@
DIST asciidoctor-2.0.18.tar.gz 1690964 BLAKE2B 5e14371c7201f83529fa28a63b031599ebf53fda62b4701942f134e7f1dae923a07676aafeac4c5e1fc3c25b6e9044b34b9b2e5b07491f1ca8e68076aa02301b SHA512 b47b377520046d95101fc9bcd3defdf7219714ebadc0d069cb108d39a349fcf1abd1e61178e1515f75bb69e9e3d0f8cb2de67de5a0f8aa75fdd139d693c0e437
DIST asciidoctor-2.0.20.tar.gz 1700888 BLAKE2B 0b09610cc4a642eacd608bfbe8054c9358aca908adba088a21deceb25374fa4796a53a619957c9974fcb576016ce6573c891b39a6c6d66aa73585cd637310ff0 SHA512 b6b730de8f83e36630dc6146b4c0e07a26b502b695e78e50fc87790391126d52ef0b6b02b82ecb225adff680c94305b4e31403cc067bdbf1740e2d759417f440
DIST asciidoctor-2.0.22.tar.gz 1707063 BLAKE2B 2e1e00f9e972e58453e731e84dc176bb9d1ef7b08e47986d9a892b53a8b29fe583de193ab8baa882b60a941fb095d8253054674d15107a4fd2ef66eff1fc41e9 SHA512 8c610e3710543334707e7f8c269d061c0e7a499d6840413a84b21ebb7909f78782942f38e831858b0dc8824f39da3da9e6e97734774e58bc64cab2b41d96d222
+DIST asciidoctor-2.0.23.tar.gz 1708942 BLAKE2B 870b0ea5be05ae4b2d91d7cfcf4d81b36f443740b591b8fd4f9bb547647cb777c5d9b03eb7982f84e6ac84ce5af3c9161a21e4d82ae56c70afd6ce138629675b SHA512 eeb6ef3268f8df2881fafccdb88480f203365d423f53ec9a42c3e9a91a6ec2d20048150019366a71ba0b2a9a0a90a6752fa7342ce558609ff8c242418e2f29c0
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.23.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.23.ebuild
new file mode 100644
index 000000000000..dbbcfc8b9eae
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.23.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubi
+ dev-ruby/haml:6
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid broken blocks_test.rb (already appears to be fixed upstream)
+ rm -f test/blocks_test.rb || die
+
+ # Avoid test depending on haml 6 binary which we currently don't install.
+ sed -e '/should \(load\|locate\) custom templates/askip "wrong haml binary"' \
+ -i test/invoker_test.rb || die
+
+ # Add missing require for URI
+ sed -e "/nokogiri/arequire 'uri'" \
+ -i test/test_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}