summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 06:01:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 08:09:11 -0400
commit629065eb8390bbc9687b923b89324a187049ce56 (patch)
treea1c41a4ca9a648d3d45d643b49a9fad6e72a5911 /dev-qt
parentsci-electronics/klayout: add 0.29.7 (diff)
downloadgentoo-629065eb8390bbc9687b923b89324a187049ce56.tar.gz
gentoo-629065eb8390bbc9687b923b89324a187049ce56.tar.bz2
gentoo-629065eb8390bbc9687b923b89324a187049ce56.zip
dev-qt/qtremoteobjects: new package, add 6.7.3, 6.8.0_rc, and live
Unkeyworded 6.8.0_rc and live have not been really tested yet, will have a closer look when 6.8.0 is due to release. Has the same problem as qtbase with test binaries, albeit unlike qtbase can take a shortcut by deleting the directory. This "could" come bite back if the package starts installing something valid there (ideal would be for upstream to stop installing junk only used by tests). Closes: https://bugs.gentoo.org/939293 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtremoteobjects/Manifest2
-rw-r--r--dev-qt/qtremoteobjects/metadata.xml21
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.7.3.ebuild49
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild49
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.8.0_rc.ebuild49
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.8.9999.ebuild49
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.9999.ebuild49
7 files changed, 268 insertions, 0 deletions
diff --git a/dev-qt/qtremoteobjects/Manifest b/dev-qt/qtremoteobjects/Manifest
new file mode 100644
index 000000000000..bdcd5080cf41
--- /dev/null
+++ b/dev-qt/qtremoteobjects/Manifest
@@ -0,0 +1,2 @@
+DIST qtremoteobjects-everywhere-src-6.7.3.tar.xz 537012 BLAKE2B 81363b9ce519dad0ac94109243dffd3043c010d125cb738f1dc49c31b0aa6324a28c055c0126b5992e63b5296781af87f59236c759f3e82121d8cf663d0950e6 SHA512 42b744dc946296bbd57ed31509b720285fd50760484243eede06ac25205fced40060601bef257745635ab4e15a59ddc8bd207dec52246adfde94078706d23e0f
+DIST qtremoteobjects-everywhere-src-6.8.0-rc.tar.xz 537292 BLAKE2B d605c2f901c7c54762b31aea4e0115eb595e0abf3d66ea1877ae24e437b3fd7c7f804aa13340f5688763e5908db2ee2a2303e51819394f40b2161f418aba088c SHA512 a3b1927adcc4b141a0909dda6bd8cc1babf4d79cb5cc0eb576f6a031f7599b18939b4aafa7124db5d01b01f4b035ca551d0b30a54655c3af06b5429998736eb3
diff --git a/dev-qt/qtremoteobjects/metadata.xml b/dev-qt/qtremoteobjects/metadata.xml
new file mode 100644
index 000000000000..2397ac7115c7
--- /dev/null
+++ b/dev-qt/qtremoteobjects/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <use>
+ <flag name="qml">Build QML/QtQuick bindings and imports</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>https://doc.qt.io/</doc>
+ <remote-id type="github">qt/qtremoteobjects</remote-id>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
+</pkgmetadata>
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.7.3.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.7.3.ebuild
new file mode 100644
index 000000000000..49b703f47ebd
--- /dev/null
+++ b/dev-qt/qtremoteobjects/qtremoteobjects-6.7.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ qml? (
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~dev-qt/qtbase-${PV}:6[gui] )
+"
+
+src_configure() {
+ # same issue as bug #913692 when tests are enabled
+ has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
+ qt6-build_src_test -j1
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ # installs 30+ test binaries like "qt6/bin/state" and, given
+ # otherwise empty, "can" delete the directory rather than list
+ rm -r -- "${D}${QT6_BINDIR}" || die
+ fi
+}
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild
new file mode 100644
index 000000000000..49b703f47ebd
--- /dev/null
+++ b/dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ qml? (
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~dev-qt/qtbase-${PV}:6[gui] )
+"
+
+src_configure() {
+ # same issue as bug #913692 when tests are enabled
+ has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
+ qt6-build_src_test -j1
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ # installs 30+ test binaries like "qt6/bin/state" and, given
+ # otherwise empty, "can" delete the directory rather than list
+ rm -r -- "${D}${QT6_BINDIR}" || die
+ fi
+}
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.8.0_rc.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.0_rc.ebuild
new file mode 100644
index 000000000000..49b703f47ebd
--- /dev/null
+++ b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.0_rc.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ qml? (
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~dev-qt/qtbase-${PV}:6[gui] )
+"
+
+src_configure() {
+ # same issue as bug #913692 when tests are enabled
+ has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
+ qt6-build_src_test -j1
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ # installs 30+ test binaries like "qt6/bin/state" and, given
+ # otherwise empty, "can" delete the directory rather than list
+ rm -r -- "${D}${QT6_BINDIR}" || die
+ fi
+}
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.8.9999.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.9999.ebuild
new file mode 100644
index 000000000000..49b703f47ebd
--- /dev/null
+++ b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ qml? (
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~dev-qt/qtbase-${PV}:6[gui] )
+"
+
+src_configure() {
+ # same issue as bug #913692 when tests are enabled
+ has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
+ qt6-build_src_test -j1
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ # installs 30+ test binaries like "qt6/bin/state" and, given
+ # otherwise empty, "can" delete the directory rather than list
+ rm -r -- "${D}${QT6_BINDIR}" || die
+ fi
+}
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.9999.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.9999.ebuild
new file mode 100644
index 000000000000..49b703f47ebd
--- /dev/null
+++ b/dev-qt/qtremoteobjects/qtremoteobjects-6.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ qml? (
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~dev-qt/qtbase-${PV}:6[gui] )
+"
+
+src_configure() {
+ # same issue as bug #913692 when tests are enabled
+ has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
+ qt6-build_src_test -j1
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ # installs 30+ test binaries like "qt6/bin/state" and, given
+ # otherwise empty, "can" delete the directory rather than list
+ rm -r -- "${D}${QT6_BINDIR}" || die
+ fi
+}