summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-28 08:25:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-28 09:14:43 +0100
commitab5ab6b89c51de8cc363d5bcb6c962c8504655ec (patch)
treeca5201c0e22c44830ddb2386a3dc4a8a41d56f5f /dev-python
parentdev-python/coverage: Bump to 7.4.0 (diff)
downloadgentoo-ab5ab6b89c51de8cc363d5bcb6c962c8504655ec.tar.gz
gentoo-ab5ab6b89c51de8cc363d5bcb6c962c8504655ec.tar.bz2
gentoo-ab5ab6b89c51de8cc363d5bcb6c962c8504655ec.zip
dev-python/a2wsgi: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/a2wsgi/Manifest1
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index 82767d37fdb6..102473ea2c2a 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1 +1,2 @@
+DIST a2wsgi-1.10.0.tar.gz 17811 BLAKE2B f88c243b2141c1ec04eb1447714f66384cd9dd630a081233f801779cc2abbebc1bcf479f3f5311e2f4b7a33ab549cce7197f78a8cf79221f6fe38131d2bd41e5 SHA512 fa92e7cdbcfe1a4ece72ce39c4d718b50f3e6b78daf0c85cbe7b933bca5dcc6d5e27d4004f58d8ce83fdaf7fcb43f25fbd481a0f5f4141f42d72ec5757dc1ab9
DIST a2wsgi-1.9.0.tar.gz 14435 BLAKE2B d0847d0bd1d7c8c834c243afcac2ddb342eb9a29469eb258dfed751e6629c98d0a81b5c84b7af6583b303a5a3b407d8bfb6a04a63e0c3606f0d564c55780f5d2 SHA512 e940e75c666635d842aad651d99335f5cafe8b4c236c9a47882ce5cf859cf5cfb6aa736028246139d8e06ac2b9ab53d0fd4e94ac2dbc2aa55a0103633edb0423
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.0.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.0.ebuild
new file mode 100644
index 000000000000..0dc9304f2b78
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest