summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-20 06:58:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-20 07:28:27 +0100
commit3968b3d0215e36f87cdd45a5d662aa72671e43b0 (patch)
tree73fcae56d0fc878c058246ab14be947e2d3b6d3a /dev-python
parentdev-python/sqlglot: Bump to 23.0.3 (diff)
downloadgentoo-3968b3d0215e36f87cdd45a5d662aa72671e43b0.tar.gz
gentoo-3968b3d0215e36f87cdd45a5d662aa72671e43b0.tar.bz2
gentoo-3968b3d0215e36f87cdd45a5d662aa72671e43b0.zip
dev-python/poetry-plugin-export: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/poetry-plugin-export/Manifest1
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/Manifest b/dev-python/poetry-plugin-export/Manifest
index 736d613fc2e2..70b648701017 100644
--- a/dev-python/poetry-plugin-export/Manifest
+++ b/dev-python/poetry-plugin-export/Manifest
@@ -1,2 +1,3 @@
DIST poetry_plugin_export-1.6.0.tar.gz 29265 BLAKE2B 90690afe197fd109d5fc5ae4566675a6a1e5e4df50cd814370146501389ba3bb0e78c2be2878cac322548ea5be065ef68f5b28a6d79a003d0f7b31c149ad0214 SHA512 d071f69ace98dbc23a3b129ba7fb30c4e6eac07138f4ee5156c266150f8f025f8b69c61dfadd90d29e1895c70d448fc44a9b5cc502024f00e1657247ed3310bd
DIST poetry_plugin_export-1.7.0.tar.gz 29196 BLAKE2B dc3db16ceee5cc727c865e141527ce4c854b2b68050ab8e4c7d03a2912f8fc7c3310653c098510198aea6254b35c875d9e837e129d327ecf0c2bec8f47c88c61 SHA512 9f458491d90b847c896416666cbd1517a1833d355ed0e59df6ae00603ef53383434f02eeb8a31069efeb9a99b1b93abd0a9b7647c9e2ff67976858be458ac95c
+DIST poetry_plugin_export-1.7.1.tar.gz 29656 BLAKE2B 130eb35064104c3f22958816447ff674d1f5aed657ada2fe23a635de52338cb736f631b622b0641aae308d69494eb939a1ea659e33fc6227bb742ee01335ae15 SHA512 d472d8e4d6eb803587722854be912009a9bc0a8f86ee0e3ef0046f385ed59236af229109dae85198e3a205702cff86780576939e518fa797f3e5093537a0d2f1
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild
new file mode 100644
index 000000000000..a1e7b242c958
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.8.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest