summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-29 07:38:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-29 07:49:18 +0200
commit2391e39e1f6c557a77d9fb2104ad3f6760d4e288 (patch)
treee6830e8094281817a9b0e3136097edcd58d05deb /dev-python
parentdev-python/fonttools: Bump to 4.39.3 (diff)
downloadgentoo-2391e39e1f6c557a77d9fb2104ad3f6760d4e288.tar.gz
gentoo-2391e39e1f6c557a77d9fb2104ad3f6760d4e288.tar.bz2
gentoo-2391e39e1f6c557a77d9fb2104ad3f6760d4e288.zip
dev-python/google-api-python-client: Bump to 2.83.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.83.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 988970a89ace..893b95f4c3c4 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.81.0.gh.tar.gz 39081445 BLAKE2B 779b22f07b12834d649982a52491b567472af7fd83f49e6b9d4a20a991dd57e5bd11e32fdba05f004449733bf5cb2fd2a5ec4a3f012a558989563c88256c3199 SHA512 72e357d68314cda2cbb6d679ad22ecedf3a1ede87b94067bbaca886bd9a17ef3f881ca6060fc23c3c8848fba96668ff0b7ba9f4b44da625f3f34bed5f537e762
DIST google-api-python-client-2.82.0.tar.gz 10656632 BLAKE2B c94f96c727f7d0cacf008791b3b480fdda3289cfb4326691de7a26d6aeb28ae11c39ef4c8e0dd06a5025e0f77ef473a87cc329b6a10857bff0ba1c4a76814d8d SHA512 913e46120dd624907f1126a00f80ad378e5a874186e09b62b9a5e31b080e5c35af7aaa28e1527c54b2697d2e1af32f02d22aa1dcaa07d3f271fba77ba654d2aa
+DIST google-api-python-client-2.83.0.tar.gz 10684846 BLAKE2B 82c8c563c2f78584d0a98ac433972ac52a38a69aa5b2eb16941372260045d9a40fd6b7ee04210824bc847fb0902f46a9d0ba376056dab16202d121dd50ca4c38 SHA512 bc05ef744aa13405c41348233d111d3f34882b30b8ef1edf9581ff96d913717bdc2281d29b28eda7119c04dba7ec133cada9b1750f159aa8d9c125cfd707881d
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.83.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.83.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.83.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}