summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-10 05:13:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-10 05:16:24 +0100
commit0889216d8f6e8e7eb9e44f597b4449ac29ae2b3f (patch)
treefa0c3fb7ce492024b51af82a1fb9e97a269357cc /dev-python
parentdev-python/bandit: Bump to 1.7.5 (diff)
downloadgentoo-0889216d8f6e8e7eb9e44f597b4449ac29ae2b3f.tar.gz
gentoo-0889216d8f6e8e7eb9e44f597b4449ac29ae2b3f.tar.bz2
gentoo-0889216d8f6e8e7eb9e44f597b4449ac29ae2b3f.zip
dev-python/unidiff: Bump to 0.7.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/unidiff/Manifest1
-rw-r--r--dev-python/unidiff/unidiff-0.7.5.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/unidiff/Manifest b/dev-python/unidiff/Manifest
index 000ec869c866..aa15204ce4c7 100644
--- a/dev-python/unidiff/Manifest
+++ b/dev-python/unidiff/Manifest
@@ -1 +1,2 @@
DIST python-unidiff-0.7.4.gh.tar.gz 17582 BLAKE2B 9b674d5b1bc434464c5b7b08b4b6527e1394633abcc6211b9f459fde545fef1c6418ad84dbe9cf7a3a308deeb2221749f50f25458306046f2930d0fcc3af9526 SHA512 b8e1d8165efcc5788707432c3c3236d97ec86ae577ff3dd7ec405809dbaef3153a835572844f7ef2a4d5d2c9b60dee586717e4cf0acf4db8049ab7c5af178a07
+DIST unidiff-0.7.5.tar.gz 20931 BLAKE2B b43ff383fdc52f2d2973a42a8178eeae46b2e73919dc4e79166fe100b3d3cc8a47c1a55f76f1f4b49d5c175eea3949e750b7c4ddea716e8f1d6faa34109cdc81 SHA512 bcb8c234643ecaf7d8227b57f90fbc546851b5e3abe84d74b33570bf3399b9be756b4dca9f1506b69e9401e724bfd9892c5deac515160685e5399bfe555716a3
diff --git a/dev-python/unidiff/unidiff-0.7.5.ebuild b/dev-python/unidiff/unidiff-0.7.5.ebuild
new file mode 100644
index 000000000000..c9a002931e1e
--- /dev/null
+++ b/dev-python/unidiff/unidiff-0.7.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unified diff parsing/metadata extraction library"
+HOMEPAGE="
+ https://github.com/matiasb/python-unidiff/
+ https://pypi.org/project/unidiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest