summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-20 19:49:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-20 20:21:20 +0100
commite94e58b87c7de67d078641a493a7e52eb6bee79d (patch)
tree68b5410adfa598e66f94b8f0e37b3635161dee4d /dev-python/unearth
parentdev-python/sentry-sdk: Bump to 1.43.0 (diff)
downloadgentoo-e94e58b87c7de67d078641a493a7e52eb6bee79d.tar.gz
gentoo-e94e58b87c7de67d078641a493a7e52eb6bee79d.tar.bz2
gentoo-e94e58b87c7de67d078641a493a7e52eb6bee79d.zip
dev-python/unearth: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest1
-rw-r--r--dev-python/unearth/unearth-0.15.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index ef936cfa7188..e9c8f1229f1f 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1 +1,2 @@
DIST unearth-0.14.0.tar.gz 280614 BLAKE2B d52ca2c8412a0e7bdf5c47d9693b4cdfe3a17ecc95d9d79ecdf7ee0cd5df7518de9cecf8efdfd88ae3f0b852c6bdc8b2c83198e23017d24a47fc6489b1c6e14e SHA512 ab785935f94a1987146471843961a4edc155e135471d4885324d1c2327527f112e03e1146f85a013ad0fd4560f803b616b12618d810becddea94abbce09096c4
+DIST unearth-0.15.0.tar.gz 283684 BLAKE2B dce9d5e9558a531f71fdbde435e61fcd5adc57def602478343d6cd370061c5e2a6c882c2f5ce2e1738bb4377340460e469e85dcc9507547823721e88f5524e56 SHA512 9cfc9f344ec4e84b9d8c6f7ae49123752377c016082bf8c37f70b1bf94d158862f72ac76d88db0bb3665b82a7aca156f52c9d8d295c8807336c83c6cfd09e98d
diff --git a/dev-python/unearth/unearth-0.15.0.ebuild b/dev-python/unearth/unearth-0.15.0.ebuild
new file mode 100644
index 000000000000..5260d38a7421
--- /dev/null
+++ b/dev-python/unearth/unearth-0.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.27.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -p pytest_mock
+}