summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 21:26:52 +0000
committerSam James <sam@gentoo.org>2021-02-27 21:39:25 +0000
commit9021b4a842099495a6ee57c47a4fe45131af65c7 (patch)
tree28788da64b54cddfb198033788574c47bf96681b /dev-python/twython
parentdev-python/requests-oauthlib: add Python 3.9 (diff)
downloadgentoo-9021b4a842099495a6ee57c47a4fe45131af65c7.tar.gz
gentoo-9021b4a842099495a6ee57c47a4fe45131af65c7.tar.bz2
gentoo-9021b4a842099495a6ee57c47a4fe45131af65c7.zip
dev-python/twython: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/twython-3.7.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/twython/twython-3.7.0.ebuild b/dev-python/twython/twython-3.7.0.ebuild
index 207c017737ed..8850d99906b5 100644
--- a/dev-python/twython/twython-3.7.0.ebuild
+++ b/dev-python/twython/twython-3.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -18,8 +18,7 @@ KEYWORDS="amd64 x86"
RDEPEND="
>=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
>=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+BDEPEND="test? ( dev-python/responses[${PYTHON_USEDEP}] )"
distutils_enable_tests unittest