summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 14:40:08 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 14:40:25 +0200
commitd586a50c2b4c2647b4dbeff9d9eed53f183453ba (patch)
treea3790c0c0f2e0302f5ffd5337aacb59fba68b9ab /dev-python/qstylizer
parentapp-emulation/virtualbox: drop versions (diff)
downloadgentoo-d586a50c2b4c2647b4dbeff9d9eed53f183453ba.tar.gz
gentoo-d586a50c2b4c2647b4dbeff9d9eed53f183453ba.tar.bz2
gentoo-d586a50c2b4c2647b4dbeff9d9eed53f183453ba.zip
dev-python/qstylizer: add 0.2.2
Closes: https://bugs.gentoo.org/838220 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/qstylizer')
-rw-r--r--dev-python/qstylizer/Manifest1
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
index 6d55a1f5df45..22488df2e8cd 100644
--- a/dev-python/qstylizer/Manifest
+++ b/dev-python/qstylizer/Manifest
@@ -1 +1,2 @@
DIST qstylizer-0.2.1.tar.gz 20687 BLAKE2B ad158ac0f88c4a0a7c6d9fe9adc611f69cb946c28be8c414dbb40532901b53faee281e7c0a798c9f680d8e5cd8a04179b16df796041133a8dd65d117964e9905 SHA512 c5e4a4194b4282a6d2782c0636ed74e9885409570466765c6e2aee0a176175bb688854244828c56ffbd00e76d297a33de211dedae8d984021c816522ea2b6085
+DIST qstylizer-0.2.2.gh.tar.gz 20752 BLAKE2B c5442821389863bc03bb0659b528322cc12f5be8137f74746e3ec7a18bf89d2822d533d13cc23842daf32a0077ad84d0e7b5dc62f231e75e57388064bd08e5fc SHA512 682f10462965a93b36f0e44b75885b9d60b4d3cd03369976b977c9b928afed4e930b6b7ef26850bdb7b40ef2a31db35a9778738582dae8715f54c1f00a957fb3
diff --git a/dev-python/qstylizer/qstylizer-0.2.2.ebuild b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
new file mode 100644
index 000000000000..7e51a4b78757
--- /dev/null
+++ b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
+HOMEPAGE="https://github.com/blambright/qstylizer"
+SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
+ <dev-python/tinycss2-2[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/inflection-1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-vcs/git
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-autoprogram
+
+python_prepare_all() {
+ # Exception: Versioning for this project requires either an sdist tarball, or access to an
+ # upstream git repository. It's also possible that there is a mismatch between the package
+ # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
+ # was given, but was not able to be found.
+ #
+ # There are no tarballs on PyPI, so we do this as a workaround
+ git init -q || die
+ git config user.email "larry@gentoo.org" || die
+ git config user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m "init" || die
+ git tag -a "${PV}" -m "${PV}" || die
+
+ distutils-r1_python_prepare_all
+}