summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-25 17:21:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-25 17:21:18 +0100
commita7133a4442c67b7db964b81bd94e2058561dd8d9 (patch)
treea98a1d23cd22c2f51ca4783d2060e5550ec09abe /dev-python/pytest-mock
parentpackage.mask: Last rite dev-python/pytest-toolbox (diff)
downloadgentoo-a7133a4442c67b7db964b81bd94e2058561dd8d9.tar.gz
gentoo-a7133a4442c67b7db964b81bd94e2058561dd8d9.tar.bz2
gentoo-a7133a4442c67b7db964b81bd94e2058561dd8d9.zip
dev-python/pytest-mock: Remove obsolete py.code import
Closes: https://bugs.gentoo.org/888215 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.10.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
index 6266e8ce070c..c71b9b8faec7 100644
--- a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
@@ -31,6 +31,12 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # obsolete, upst. e2016928db1147a2a46de6ee9fa878ca0e9d8fc8
+ sed -i -e '/import py\.code/d' tests/test_pytest_mock.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin