summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-17 21:03:01 +0100
committerMarek Szuba <marecki@gentoo.org>2022-01-17 22:07:59 +0100
commit7c01a4afd41e3651777c6621cfef64d99f901217 (patch)
treef82ce30b3e6c58e7b5f86ddf705b8f424c165cb8 /dev-python/pyopencl/pyopencl-2021.2.13.ebuild
parentapp-containers/cri-tools: Bump to version 1.23.0 (diff)
downloadgentoo-7c01a4afd41e3651777c6621cfef64d99f901217.tar.gz
gentoo-7c01a4afd41e3651777c6621cfef64d99f901217.tar.bz2
gentoo-7c01a4afd41e3651777c6621cfef64d99f901217.zip
dev-python/pyopencl: add 2021.2.13, drop 2021.2.11
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2021.2.13.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.13.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopencl/pyopencl-2021.2.13.ebuild b/dev-python/pyopencl/pyopencl-2021.2.13.ebuild
new file mode 100644
index 000000000000..239c5dd9b960
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.2.13.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+DEPEND=">=virtual/opencl-2"
+RDEPEND="${DEPEND}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+# libglvnd is only needed for the headers
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}