summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-13 06:58:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-13 07:06:24 +0200
commit061aa073a5d9f2b79a2cbb9c9b3ca149015b7ce9 (patch)
tree92c4b86f9ae7a91f00a2248d8c2d44102ff23316 /dev-python/openapi-core
parentdev-python/json5: Remove old (diff)
downloadgentoo-061aa073a5d9f2b79a2cbb9c9b3ca149015b7ce9.tar.gz
gentoo-061aa073a5d9f2b79a2cbb9c9b3ca149015b7ce9.tar.bz2
gentoo-061aa073a5d9f2b79a2cbb9c9b3ca149015b7ce9.zip
dev-python/openapi-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.16.0.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 9f2fbc02ca82..84d0fc5323a0 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,3 +1,2 @@
DIST openapi-core-0.14.5.gh.tar.gz 57645 BLAKE2B c5c9c308b93a37e32708677cc7c7a2ccb9ec3f018390e56a251224b6b8776943ccd0ddfb560cdc3f1182cb32a9b2817878a0d4dda3906c179db9841853caf7ac SHA512 69d9fb2cc21dfdb939beae45b1c681faf9f8e3366b36e5907b00be65ac669ec40e3ae3fe910fb2c4f6c70d1412e6a67e4e4e47e3cf2c424716da4c813223295e
-DIST openapi-core-0.16.0.gh.tar.gz 79041 BLAKE2B 93745787d39dc2e77e6b268792548069e7637ea7acbf4975224d837b87f301ea5ae36c07aec5b8f44b6e7a5480aab744e9601663f080d63f27b8a49aeb9cd7f5 SHA512 70ed773926c16df9d085e7ce104a0a99ccc52e8e0ba395ead1cf5e9cba1e43723bb7a744cd2b9c27e3a8a48319f8265dc5745c20cc23e825fa28ed3b2fcd3e25
DIST openapi-core-0.16.1.gh.tar.gz 79002 BLAKE2B 2b64a28c80b64294cdbef2e4fcd08bfdc739c53a6baf0aeacc9e082bc01c8bf1b58da53a8c9b5b80a38600e4ab8bfb67b1d7ebb3a759d60d43748c9cc09c8eba SHA512 87cd47871a939b9f0ab23deafac067d16ba88146e140e7602b8bec5498ea6ed2213ceb530c9448718c5f94b944a954f2d46fab3fb18cacc2764a5cd7bf056dff
diff --git a/dev-python/openapi-core/openapi-core-0.16.0.ebuild b/dev-python/openapi-core/openapi-core-0.16.0.ebuild
deleted file mode 100644
index 0f2ba12ece92..000000000000
--- a/dev-python/openapi-core/openapi-core-0.16.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/p1c2u/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-SRC_URI="
- https://github.com/p1c2u/openapi-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.4[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.3[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/asgiref[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/starlette-0.21.0[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # falcon is not packaged
- tests/integration/contrib/falcon
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/django/test_django_project.py
- tests/unit/contrib/django/test_django.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}