summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/objgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/objgraph')
-rw-r--r--dev-python/objgraph/Manifest2
-rw-r--r--dev-python/objgraph/metadata.xml12
-rw-r--r--dev-python/objgraph/objgraph-1.7.2.ebuild27
-rw-r--r--dev-python/objgraph/objgraph-1.8.1.ebuild27
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/objgraph/Manifest b/dev-python/objgraph/Manifest
new file mode 100644
index 000000000000..d5a670e87b2b
--- /dev/null
+++ b/dev-python/objgraph/Manifest
@@ -0,0 +1,2 @@
+DIST objgraph-1.7.2.tar.gz 545016 SHA256 3b08ccf1f06b8c13574c1edf4767fd9b50607a41218cf8a64f12e2f7a8be4d70 SHA512 22012031723060b47058c00cd97035b53238f8cf49c4e51b1f7735bf9c1d5aac9a5f0bcbe605317952f9b9390fc3bf247211082b4540e05cbf76670c27861ac2 WHIRLPOOL 23a017ac5fd9fa7ed266bc92675cb6d20afc38b2291465ba76414f1ff11edd42856732ffab1a187ebf8d683a1393f51cf7406104938fadf0fd286963fba6000e
+DIST objgraph-1.8.1.tar.gz 549402 SHA256 b4d4628adf39176beeb881fc575832256756bf0d73c1746b2b3529fd309b1a67 SHA512 c09e66aecc5dadc5a6e3d93e0f97fa6e816c5cbe968540400ed3d1248b958c955648cb2b4247ba00cd2388302dbcc178c55686cd2b95858b965a2717c6ff0c90 WHIRLPOOL f8e273422079249e0a22aa8f136fed72aa2fb1f8b925acfe52bf4677ac6164cc2ef919b5e4c23ab81ee978c94563366b52c52ed00c82ff8ce17056e644471c17
diff --git a/dev-python/objgraph/metadata.xml b/dev-python/objgraph/metadata.xml
new file mode 100644
index 000000000000..0641e64317ea
--- /dev/null
+++ b/dev-python/objgraph/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+ <longdescription>A module that lets you visually explore Python object graphs.</longdescription>
+ <upstream>
+ <remote-id type="pypi">objgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/objgraph/objgraph-1.7.2.ebuild b/dev-python/objgraph/objgraph-1.7.2.ebuild
new file mode 100644
index 000000000000..717426727f13
--- /dev/null
+++ b/dev-python/objgraph/objgraph-1.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="http://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/objgraph/objgraph-1.8.1.ebuild b/dev-python/objgraph/objgraph-1.8.1.ebuild
new file mode 100644
index 000000000000..d120aba9de86
--- /dev/null
+++ b/dev-python/objgraph/objgraph-1.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="http://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+
+ distutils-r1_python_install_all
+}