summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-04-25 10:06:09 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-18 20:02:52 +0200
commite399942ee32735947587877559003d67b894b25b (patch)
treedc31cfa6c2c0a09c65c92953a1ebd8f9164b3256 /dev-python/matplotlib2tikz
parentdev-python/ImageHash: New package (diff)
downloadgentoo-e399942ee32735947587877559003d67b894b25b.tar.gz
gentoo-e399942ee32735947587877559003d67b894b25b.tar.bz2
gentoo-e399942ee32735947587877559003d67b894b25b.zip
dev-python/matplotlib2tikz: Version bump to 0.6.7
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-init_pipdated.patch13
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.7.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index dd340f68a6b8..e3fea28df9ba 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.6.3.tar.gz 26288 SHA256 c096d75fdfe65ef4afd8aa374c5fb4b540fc13154d1ee117841ad5b67e494827 SHA512 01adffcd9d627494eb73e1f092e6ee3d6ad1b0ece96fb749a09c73942fc6a253abb3518dc8d11a2398c3fcb3b2c1e26b1dc5dc02f1e9671c4c12754f9ac6907b WHIRLPOOL 363a896f9fe5b648992767cb5449928e30141ed3aea5182a6c119af50f0793f7c0cb2e2d0daae3b4d78fb9c91af6c1ea0233f9407a0658d3be8dc1d76cf52151
+DIST matplotlib2tikz-0.6.7.tar.gz 523464 SHA256 ba95bbf5f654abccee6c3e9ab9bdd4e7fc6cab5d49def072d1c7a9020b7b602e SHA512 9128eb7cabcd44ed84ac5d9b125dc897d2901cd4d29a8aa6bbd48c35c6418f4b5cd5b8e7c55e7690fe927c704580fe2d83084c37d515c9a25ee67ea476a63e4d WHIRLPOOL f1cd962ebafab85adbd8bbaaf6f565e1312d610bfd7cd0827f60535432ce952ae6e5535860e754ad872cdfffaa70bb72d4cfb676adb91b2624f5ab060969fd7b
diff --git a/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-init_pipdated.patch b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-init_pipdated.patch
new file mode 100644
index 000000000000..396513f31463
--- /dev/null
+++ b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-init_pipdated.patch
@@ -0,0 +1,13 @@
+Remove version checks using pipdated.
+
+Patch by Marius Brehler <marbre@linux.sungazer.de>
+--- a/matplotlib2tikz/__init__.py
++++ b/matplotlib2tikz/__init__.py
+@@ -15,7 +15,3 @@ from matplotlib2tikz.__about__ import (
+ )
+
+ from matplotlib2tikz.save import get_tikz_code, save
+-
+-import pipdated
+-if pipdated.needs_checking(__name__):
+- print(pipdated.check(__name__, __version__))
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.7.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.7.ebuild
new file mode 100644
index 000000000000..c08121bee49a
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}/${P}-init_pipdated.patch" )
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}